Bug 176348 - cannot enter single user mode after update to 2.86 based SysVinit
cannot enter single user mode after update to 2.86 based SysVinit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sysvinit (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 12:12 EST by Thomas M Steenholdt
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.86-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 12:25:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2005-12-21 12:12:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051206 Fedora/1.5-0.tmus.1 Firefox/1.5

Description of problem:
After a recent update to SysVinit-2.86-1, kernel command line arguments single, s S and 1 does not make the system boot into single user mode.

Version-Release number of selected component (if applicable):
SysVinit-2.86-1

How reproducible:
Always

Steps to Reproduce:
1. try the traditional single user mode flags on the kernel cmdline
2. watch as the system flies into runlevel 5

  

Actual Results:  runlevel 5

Expected Results:  single user mode

Additional info:

I tried to downgrade to FC4 version (SysVinit-2.85-39) and the flags now successfully make the system boot into single user mode.

At this point I don't know whether this is caused by an actual SysVinit bug, a script compability issue or something else.

I did try to boot with "selinux=0 s" and that didn't help much - still booted straight through to runlevel 5, so i doubt it's directly related to SElinux.
Comment 1 Bill Nottingham 2005-12-21 12:25:11 EST
Fixed in -2, it was a new sysvinit bug in 2.86.
Comment 2 Thomas M Steenholdt 2005-12-21 12:32:58 EST
wow - bug squashed in < 15 mins, that's gotta be some kind of record :)
Comment 3 Bill Nottingham 2005-12-21 12:41:00 EST
To be honest, I read about it on the list beforehand, and was already working on
it. :)
Comment 4 Thomas M Steenholdt 2005-12-21 14:43:46 EST
I knida knew, but "read ahead" is still considered fair play, so it doesn't
impact resolve time :)
Comment 5 David Lawrence 2007-06-21 22:11:21 EDT
Package name is now sysvinit in Fedora.

Note You need to log in before you can comment on or make changes to this bug.