Bug 176349 - RFE: Update enscript to 1.6.4
RFE: Update enscript to 1.6.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enscript (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 12:13 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.6.4-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 07:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-12-21 12:13:29 EST
It would be nice to get enscript updated to 1.6.4 for FC5.  All other major
distributions seem to have shipped it already for a while.

1.6.4 is available from the maintainer's site: http://www.iki.fi/mtr/genscript/
It's listed as "beta" but is already almost 3 years old...

Personally, my interest towards getting it updated is because newer versions of
it include extensible source code formatting capabilities, for example to HTML.
 Applications that could use that functionality include at least CVSweb, ViewVC
(ex-ViewCVS), and Trac.
Comment 1 Tim Waugh 2005-12-21 12:32:51 EST
Perhaps the maintainer could be persuaded to actually release this version out
of beta?
Comment 2 Ville Skyttä 2006-01-08 16:29:45 EST
Thanks, seems to be working nicely.

There are quite a few additional highlighters available here and there, and I
have  a local package which integrates a bunch of them.  The "problem" is that
installing them properly requires patching states/hl/enscript.st which is not
practical in additional packages.

Would you be interested in applying a patch to the main enscript package
containing these additional highlighters?
Comment 3 Tim Waugh 2006-01-09 08:18:24 EST
Sure (separate bug report please).

Note You need to log in before you can comment on or make changes to this bug.