Bug 1763519 - qcow2 corruption
Summary: qcow2 corruption
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-20 17:22 UTC by David Sebek
Modified: 2019-11-12 11:10 UTC (History)
11 users (show)

Fixed In Version: qemu-4.1.0-5.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-02 02:28:00 UTC
Type: Bug


Attachments (Terms of Use)
sudo qemu-img check mi-rev-win10.qcow2 &> qemu-img_check.txt (1.15 MB, text/plain)
2019-10-20 17:22 UTC, David Sebek
no flags Details

Description David Sebek 2019-10-20 17:22:11 UTC
Created attachment 1627499 [details]
sudo qemu-img check mi-rev-win10.qcow2 &> qemu-img_check.txt

Description of problem:
About a week ago I created a Windows 10 VM using virt-manager. Everything worked OK until I started the VM today (it was started only a few times before). Some file system corruption was detected and automatically fixed by the guest Windows 10 OS during its bootup. Now some of the components of the guest Windows operating system do not work.
Checking the qcow2 virtual disk image using the "qemu-img check" command returns a bunch of errors.

Version-Release number of selected component (if applicable):
[david@dsebek-pc KVM]$ qemu-kvm --version
QEMU emulator version 4.1.0 (qemu-4.1.0-2.fc31)
Copyright (c) 2003-2019 Fabrice Bellard and the QEMU Project developers
[david@dsebek-pc KVM]$ virt-manager --version
2.2.1


How reproducible:
I haven't tried to reproduce it.

Steps to Reproduce:
1. Start creating a new Windows 10 virtual machine using virt-manager.
2. Create a QCOW2 disk image.
3. Select UEFI instead of BIOS.
4. Use VirtIO SCSI as a disk controller.
5. Set 'discard' option to 'unmap' in VM's disk section.
6. Finish creating the VM, install the guest Windows 10 Pro operating system.
7. Use the VM for a few hours, turn it on and off a few times.
8. A file system corruption will occur on the guest OS, "qemu-img check" will return errors.

Actual results:
Corruption of qcow2 disk image was experienced.

Expected results:
No corruption of qcow2 disk image is expected.

Additional info:
Host machine uses Fedora 31, Luks, Ext4, fstrim about once in a few days.

Comment 1 David Sebek 2019-10-23 20:11:28 UTC
Related bug report: https://bugs.launchpad.net/qemu/+bug/1846427

Comment 2 Richard W.M. Jones 2019-10-23 20:26:08 UTC
Thanks for finding that upstream bug.  I've subscribed to it so let's
see what fix they come up with.  It sounds (from the upstream bug) as if
it's something pretty serious.  Should we unpush this version of qemu for
a while?

Comment 3 Cole Robinson 2019-10-24 15:36:10 UTC
I'm doing a build with 69f47505ee66afaa513305de0c1895a224e52c45 reverted, which kwolf suggested

Comment 4 Fedora Update System 2019-10-24 22:02:46 UTC
FEDORA-2019-9a30568ecf has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9a30568ecf

Comment 5 Fedora Update System 2019-10-26 15:31:57 UTC
qemu-4.1.0-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9a30568ecf

Comment 6 Fedora Update System 2019-11-02 02:28:00 UTC
qemu-4.1.0-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 cody6730 2019-11-05 16:29:16 UTC
I'm having what seems to be the same problem, as referenced in this bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1768541

The problem still exists in qemu-4.1.0-5.fc31. It is impossible to overstate the seriousness of this bug. The upgrade to Fedora 31 has caused the unrecoverable loss of every virtual machine that existed on this machine.


Note You need to log in before you can comment on or make changes to this bug.