Bug 1763636 - etcd-member manifest rendered with an empty image reference and leading to cluster disruption during a 4.1->4.2 upgrade
Summary: etcd-member manifest rendered with an empty image reference and leading to cl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Antonio Murdaca
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On: 1763635
Blocks: 1763638
TreeView+ depends on / blocked
 
Reported: 2019-10-21 08:26 UTC by Antonio Murdaca
Modified: 2019-10-30 04:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1763635
: 1763638 (view as bug list)
Environment:
Last Closed: 2019-10-30 04:45:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3151 0 None None None 2019-10-30 04:45:19 UTC

Description Antonio Murdaca 2019-10-21 08:26:00 UTC
+++ This bug was initially created as a clone of Bug #1763635 +++

Description of problem:

During a 4.1.z to 4.2.z upgrade the etcd-member.yaml master manifest is being rendered with an empty image reference by the MCO (which is where the template lives and the render happens).
As a result, etcd fails to run, etcd-quorum-guard is fooled and the upgrade completely disrupts the cluster as it loses quorum.


Version-Release number of selected component (if applicable):

from 4.1 onwards

How reproducible:

1/20

Steps to Reproduce:
1. CI and or manual testing, 1/20 will fail
2.
3.

Actual results:

cluster disruption

Expected results:

upgrade successful


Additional info:

Comment 4 errata-xmlrpc 2019-10-30 04:45:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3151


Note You need to log in before you can comment on or make changes to this bug.