Bug 1763663 - Double logging when downloading repository metadata
Summary: Double logging when downloading repository metadata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.1
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: 8.0
Assignee: Packaging Maintenance Team
QA Contact: Luca Berton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-21 09:51 UTC by Pavla Kratochvilova
Modified: 2020-04-28 16:49 UTC (History)
3 users (show)

Fixed In Version: dnf-4.2.11-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:17 UTC

Description Pavla Kratochvilova 2019-10-21 09:51:43 UTC
When repository metadata are loaded from dnf cli and skip_if_unavailable=False, the error on failure is logged twice.

# dnf repolist --repo=repo-id
Failed to download metadata for repo 'repo-id'
Error: Failed to download metadata for repo 'repo-id'

Additional note: This bug was caused by a fix for bug #1589832, where we added log to the API method dnf.repo.Repo.load(). However, the bug was later fixed on the Anaconda's side, too, and the additional log in in the method is no longer needed (an exception raised from the method is sufficient).

Comment 1 Pavla Kratochvilova 2019-10-21 09:53:51 UTC
PR: https://github.com/rpm-software-management/dnf/pull/1475
Tests in ci-dnf-stack: https://github.com/rpm-software-management/ci-dnf-stack/pull/643
Note the tests also cover additional changes in logging, but this bug is tested by them, too.

Comment 10 errata-xmlrpc 2020-04-28 16:49:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.