Bug 1763693 - vim-X11-8.1.2168-1.fc31.x86_64: spell check seems to have broken
Summary: vim-X11-8.1.2168-1.fc31.x86_64: spell check seems to have broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-21 11:18 UTC by Ankur Sinha (FranciscoD)
Modified: 2019-10-26 17:27 UTC (History)
4 users (show)

Fixed In Version: vim-8.1.2198-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-26 17:27:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Ankur Sinha (FranciscoD) 2019-10-21 11:18:36 UTC
Description of problem:
With `set spell` and `set spelllang=en_gb`, the spell check seems to be broken now.


Version-Release number of selected component (if applicable):
vim-X11-8.1.2168-1.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run new vim instance: `gvim -u NONE` to ensure that no plugins or config are loaded
2. In vim, go `:set spell`, `:set spelllang=en_gb` to enable spellcheck with en_gb
3. Write "Hello."

Actual results:
It is underlined as a spelling error. `z=` shows lots of weird spelling suggestions.

Expected results:
Should not think of this as a spelling error.

Additional info:

Comment 1 Ankur Sinha (FranciscoD) 2019-10-21 11:28:33 UTC
This may not be limited to en_gb. Even with spelllang=en, vim tells me that "Apologies" is a spelling error now..?

Comment 2 Garry T. Williams 2019-10-21 19:02:47 UTC
(In reply to Ankur Sinha (FranciscoD) from comment #1)
> This may not be limited to en_gb. Even with spelllang=en, vim tells me that
> "Apologies" is a spelling error now..?

It's not limited to en_gb.  spelllang=en here.

Many words as first word of line are marked with red squiggly line starting at their *second* character.  Words after the first word on a line seem to be marked or not marked correctly.

$ gvim --version
VIM - Vi IMproved 8.1 (2018 May 18, compiled Oct 17 2019 00:00:00)
Included patches: 1-2168
Modified by <bugzilla@redhat.com>
Compiled by <bugzilla@redhat.com>
...

Comment 3 Ankur Sinha (FranciscoD) 2019-10-22 09:58:51 UTC
Yeh, same here. Updating bug summary, increasing severity.

Comment 4 Zdenek Dohnal 2019-10-22 10:37:42 UTC
Hi Ankur and Garry,

thank you for reporting the issue.

I was able to reproduce the issue with patchlevel 2168 and the issue is no more with patchlevel 2197+.

I'll rebuild Vim.

Comment 5 Ankur Sinha (FranciscoD) 2019-10-22 11:49:55 UTC
Thanks---the new build fixes the regression for me. Left karma on the update also.

Comment 6 Fedora Update System 2019-10-22 12:03:54 UTC
FEDORA-2019-07d47de9fc has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-07d47de9fc

Comment 7 Fedora Update System 2019-10-23 15:44:24 UTC
vim-8.1.2198-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-07d47de9fc

Comment 8 Fedora Update System 2019-10-26 17:27:13 UTC
vim-8.1.2198-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.