Bug 1763712 - xterm could be ./configured with --enable-sixel-graphics
Summary: xterm could be ./configured with --enable-sixel-graphics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Korbar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-21 12:11 UTC by Antony Lee
Modified: 2019-11-07 01:17 UTC (History)
2 users (show)

Fixed In Version: xterm-349-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 01:17:22 UTC


Attachments (Terms of Use)

Description Antony Lee 2019-10-21 12:11:22 UTC
Description of problem:

xterm optionally supports sixel graphics (https://en.wikipedia.org/wiki/Sixel, https://github.com/saitoha/libsixel -- note that the latter just shows some uses of sixel graphics, and is not a dependency for the following).

As of xterm package 334-2.fc30 the option is not enabled in Fedora's build; passing --enable-sixel-graphics to ./configure would enable it.  This flag should bring no additional dependencies and no downsides other than slightly longer compilation time and slightly larger final binary size, so it would be nice to have it.

Note that both Debian and Arch (for example) already enable this flag:
https://packages.debian.org/buster/xterm
https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/xterm#n44


Version-Release number of selected component (if applicable): 334-2.fc30

How reproducible: N/A

Steps to Reproduce: N/A

Actual results: N/A

Expected results: N/A

Additional info: N/A

Comment 1 Fedora Update System 2019-10-29 09:58:11 UTC
FEDORA-2019-5cea1d8839 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5cea1d8839

Comment 2 Tomas Korbar 2019-10-29 10:58:07 UTC
Hi Antony,
Thanks for reporting this. Sixel graphics is definitely an interesting feature. Xterm in rawhide is updated and i created update for f31 so feel free to try it and give karma:)

Comment 3 Antony Lee 2019-10-29 13:08:10 UTC
Thanks for the update.  I will wait for F31 to try this, as it looks like it'll be released very soon.

Comment 4 Tomas Korbar 2019-10-29 13:32:51 UTC
Yeah i think it will be released today [0] :)
[0] https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/N44O3QSRZJTWWXLXOP3JX2U2BTWHM3TE

Comment 5 Antony Lee 2019-10-29 15:02:13 UTC
Yes, it works, thanks!

Comment 6 Fedora Update System 2019-10-30 01:29:47 UTC
xterm-349-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5cea1d8839

Comment 7 Fedora Update System 2019-11-07 01:17:22 UTC
xterm-349-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.