Bug 176384 - (Audiossis) Kfloppy cannot format a floppy disk in KDE 3.4/3.5
Kfloppy cannot format a floppy disk in KDE 3.4/3.5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 19:31 EST by Ben Phillips
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 17:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Phillips 2005-12-21 19:31:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I noticed a problem when trying to format a floppy disk using Kfloppy under Fedora C4/KDE 3.4.

Under KDE3.4, Kfloppy returned an error that read "cannot access device fd0u1440".

Under KDE3.4 I was able to temporarily fix the issue by typing this command at the command prompt "ln -s /dev/fd0 /dev/fd0u1440" as the super-user in /dev directory. This worked until the computer was rebooted where upon I then had to re-type the command in /dev to get Kfloppy working again.

In the hope that this bug may have been fixed, I updated my system to KDE3.5 (using yum). No luck, Kfloppy still does not work but the error message has changed. It now reads "Internal error: Device not correctly defined".
Opening a command prompt in the /dev directory and entering the "ln -s /dev/fd0 /dev/fd0u1440" command as before does get the program working, but with the same limitations as under KDE3.4 and when I try to perform a "Full Format" Kfloppy returns the error "Device Busy: Perhaps you need to unmount the device first? The program fdformat terminated with an error". Only the "Quick Format" and the "Zero out and Quick Format" options work properly under these circumstances.

Is this a bug with the program or are my system settings incorrect? Is there a script I can generate as a permanent workaround? If so how would I go about generating it?

Incidentally, this problem does not appear when I log into the Gnome environment. Floppy Formatter under Gnome works perfectly (it's just painful having to flip between desktop environments all the time).

Version-Release number of selected component (if applicable):
kdeutils-3.5.0-0.1.fc4.s

How reproducible:
Always

Steps to Reproduce:
1.No special requirements. Simply execute Kfloppy from either KDE3.4 or KDE3.5
2.
3.
  

Actual Results:  Kfloppy returned an error. "Internal Error: Device not correctly configured".

Expected Results:  Kfloppy should not have returned this error.

Additional info:

ame        : kdeutils                     Relocations: /usr
Version     : 3.5.0                             Vendor: Red Hat, Inc.
Release     : 0.1.fc4                       Build Date: Tue 13 Dec 2005 10:58:42
 PM EST
Install Date: Thu 22 Dec 2005 12:29:18 AM EST      Build Host: hs20-bc1-5.build.
redhat.com
Group       : Applications/System           Source RPM: kdeutils-3.5.0-0.1.fc4.s
rc.rpm
Size        : 9774272                          License: GPL
Signature   : DSA/SHA1, Sat 17 Dec 2005 05:36:33 PM EST, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.kde.org
Summary     : K Desktop Environment - Utilities
Description :
Utilities for the K Desktop Environment.
Includes: ark (tar/gzip archive  manager); kab (address book); karm (personal
time tracker); kcalc (scientific calculator); kedit (simple text editor);
kfloppy (floppy formatting tool); khexedit (hex editor); kjots (note taker);
klipper (clipboard tool); kljettool(HP printer configuration tool); klpq
(print queue manager) knotes (post-it notes for the desktop); kpm
(process manager similar to 'top', but more advanced);kwrite (improved
text editor).
Comment 1 Ngo Than 2006-06-22 17:04:28 EDT
It's a bug in udev. It should create /dev/fd0u1440 inode file.
i cannot reproduce it in FC5 and rawhide anymore. I'm not sure if it's fixed 
in FC4. You should please try again.

If the bug still appears, please fill new bug against udev. Thanks for your 
report

Note You need to log in before you can comment on or make changes to this bug.