Bug 1763843 - Deleting organization by title does not work in hammer
Summary: Deleting organization by title does not work in hammer
Keywords:
Status: ON_DEV
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: 6.8.0
Assignee: Shira Maximov
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-21 17:50 UTC by Lai
Modified: 2020-05-25 14:51 UTC (History)
7 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_katello-0.21.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 28833 Normal Closed Deleting organization by title does not work in hammer 2020-05-25 09:23:51 UTC

Description Lai 2019-10-21 17:50:29 UTC
Description of problem:
Running hammer organization delete --title <title name> gives error.

Version-Release number of selected component (if applicable):
6.6.0_024

How reproducible:
100%

Steps to Reproduce:
1.hammer organization delete --title <title name>

Actual results:
Could not delete the organization:
  Missing arguments for 'id'


Expected results:
[......................................................................................] [100%]

Additional info:
The expected result is what I really see if I ran the delete command successfully since there's no message that says "Organization Title <title name> deleted successfully."

Comment 3 Shira Maximov 2019-10-22 06:53:29 UTC
I tried to reproduce the issue on hammer downstream versions 0.17 and master. and I wasn't able to reproduce the BZ.
Lai, please provide hammer logs and also specify the hammer version you are working with. 
also, please check if you are able to delete the organization by the title in the API, so I can have a better understanding of the source of the issue.

Comment 7 Shira Maximov 2020-01-22 10:36:09 UTC
Created redmine issue https://projects.theforeman.org/issues/28833 from this bug

Comment 8 Bryan Kearney 2020-01-22 11:04:04 UTC
Upstream bug assigned to mshira@redhat.com

Comment 9 Bryan Kearney 2020-01-22 11:04:07 UTC
Upstream bug assigned to mshira@redhat.com

Comment 10 Bryan Kearney 2020-01-28 13:03:36 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/28833 has been resolved.


Note You need to log in before you can comment on or make changes to this bug.