Bug 176401 - I810 /i915 driver claims to enable DRI but it is not enabled
I810 /i915 driver claims to enable DRI but it is not enabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://math.columbia.edu/~neumann/i81...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 01:20 EST by Walter Neumann
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 17:09:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Neumann 2005-12-22 01:20:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5

Description of problem:
Machine Dell Latitude D410

Using the i810 driver the log Xorg.0.log shows 

(II) I810(0): [DRI] installation complete
(II) I810(0): direct rendering: Enabled

however glxinfo shows "direct rendering: No"
and graphics acceleration is not working.

Full xorg.conf and log are here:

http://math.columbia.edu/~neumann/xorg.conf 
http://math.columbia.edu/~neumann/Xorg.0.log

Searching the web, this seems to be a problem with recent kernels in some distributions when using the i810/i915 drivers. 

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1653_FC4

How reproducible:
Always

Steps to Reproduce:
1.use recommended i810 driver with Intel i915GM graphics 
2.enable dri
3.log shows dri enabled but it is not enabled
  

Actual Results:  log shows dri enabled but it is not enabled and graphics is slow: not accelerated.

Expected Results:  Graphics should be accelerated (reportedly OK with some older kernels, but I have not checked).

Additional info:
Comment 1 Dave Jones 2005-12-23 14:56:30 EST
can you try the kernel from http://people.redhat.com/davej/kernels/Fedora/FC4 ,
and attach a dmesg -s 128000 output please ?
Comment 2 Walter Neumann 2005-12-23 17:09:16 EST
No change with kernel-2.6.14-1.1775_FC4.i686.rpm. But Alan Hourihane says this
is not a bug, it is simply that X.Org 6.8.2 doesn't have any DRI support for the
i915GM. See 
http://lists.freedesktop.org/archives/xorg/2005-December/011822.html

Apparantly later X.Org has support, so it is probably fixed in Rawhide, but yum
throws up too many dependency issues when I try to upgrade to rawhide's
xorg-x11, so I havn't tried that.

Note You need to log in before you can comment on or make changes to this bug.