Bug 176404 - gnome-volume-manager crashes when inserting USB media
gnome-volume-manager crashes when inserting USB media
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 02:43 EST by Ian Burrell
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 16:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2005-12-22 02:43:31 EST
Description of problem:

gnome-volume-manager crashes when new media is inserted.  This happens with both
an USB multi-card read and USB single card reader.

Version-Release number of selected component (if applicable):

gnome-volume-manager-1.5.7-1.x86_64
dbus-0.60-1.1.x86_64
hal-0.5.5.1-2.1.x86_64
udev-077-2.x86_64
kernel-2.6.14-1.1777_FC5.x86_64

How reproducible: Every time

Steps to Reproduce:
1. Start /usr/bin/gnome-volume-manager
2. Insert flash media
3. Crash
  
Additional info:

Backtrace was generated from '/usr/bin/gnome-volume-manager'

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912509019712 (LWP 3670)]
0x00002aaaaae5aff5 in __libc_waitpid (pid=3685, stat_loc=0x7fffff97a3bc,
    options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
32            return INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
#0  0x00002aaaaae5aff5 in __libc_waitpid (pid=3685, stat_loc=0x7fffff97a3bc,
    options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
#1  0x0000003cb85526d9 in libgnomeui_segv_handle (signum=11)
    at gnome-ui-init.c:786
#2  <signal handler called>
#3  0x0000003308a39573 in _dbus_marshal_write_basic (str=0x597b38,
    insert_at=20, type=115, value=0x406c4e, byte_order=108,
    pos_after=0x7fffff97a930) at dbus-marshal-basic.c:808
#4  0x0000003308a1a929 in _dbus_type_writer_write_basic (
    writer=0x7fffff97a910, type=115, value=0x406c4e)
    at dbus-marshal-recursive.c:2402
#5  0x0000003308a201bd in dbus_message_iter_append_basic (iter=0x7fffff97a900,
    type=115, value=0x406c4e) at dbus-message.c:2132
#6  0x0000003308a20615 in dbus_message_append_args_valist (message=)
    at dbus-message.c:1295
#7  0x0000003308a2196c in dbus_message_append_args (message=0x597af0,
    first_arg_type=115) at dbus-message.c:1200
#8  0x000000000040490c in gvm_device_mount (
    udi=0x59bd14 "/org/freedesktop/Hal/devices/volume_uuid_434B_B5C6",
    apply_policy=1) at manager.c:1265
#9  0x00000000004059e6 in block_device_added (
    udi=0x59bd14 "/org/freedesktop/Hal/devices/volume_uuid_434B_B5C6",
    capability=) at manager.c:1680
#10 0x000000000040482b in hal_device_added (ctx=) at manager.c:1839
#11 0x000000330c603dbd in filter_func (connection=) at libhal.c:687
#12 0x0000003308a12d78 in dbus_connection_dispatch (connection=0x5962d0)
    at dbus-connection.c:3629
#13 0x000000330d40a022 in message_queue_dispatch (source=) at dbus-gmain.c:113
#14 0x0000003305c24ba1 in IA__g_main_context_dispatch (context=0x53fda0)
    at gmain.c:1913
#15 0x0000003305c278be in g_main_context_iterate (context=0x53fda0, block=1,
    dispatch=1, self=) at gmain.c:2544
#16 0x0000003305c27c10 in IA__g_main_loop_run (loop=0x5980f0) at gmain.c:2748
#17 0x0000003cb6c0bbf5 in IA__gtk_main () at gtkmain.c:991
#18 0x0000000000404f84 in main (argc=) at manager.c:2346
#19 0x00002aaaaaf80dc4 in __libc_start_main (main=0x404a8d <main>, argc=1,
    ubp_av=0x7fffff97b1c8, init=) at libc-start.c:231
#20 0x0000000000403a29 in _start ()
#21 0x00007fffff97b1b8 in ?? ()
#22 0x0000000000000000 in ?? ()

Thread 1 (Thread 46912509019712 (LWP 3670)):
#0  0x00002aaaaae5aff5 in __libc_waitpid (pid=3685, stat_loc=0x7fffff97a3bc,
    options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
        oldtype =
Comment 1 Ian Burrell 2006-01-29 18:53:29 EST
This bug hasn't been a problem recently.  gnome-volume-manager seems to be
working well as of 1.5.11-1.x86_64.
Comment 2 Matthias Clasen 2006-02-15 16:22:14 EST
ok, assuming its fixed then.

Note You need to log in before you can comment on or make changes to this bug.