Bug 176410 - Eclise hangs/fails to start with not apparent error.
Eclise hangs/fails to start with not apparent error.
Status: CLOSED DUPLICATE of bug 174612
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 05:51 EST by Gilboa Davara
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 19:45:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2005-12-22 05:51:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051222 Fedora/1.5-3 Firefox/1.5

Description of problem:
When I attempt to start eclipse I get a weird error code (see below) and eclipse hangs. (The process doesn't die)

Error message:
=======================================================
JVM terminated. Exit code=1
/usr/bin/java
-Xms64M
-Xmx256M
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/share/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 4b8013
-data /home/gilboa/workspace
-vm /usr/bin/java
/vmargs
-Xms64M
-Xmx256M
-jar /usr/share/eclipse/startup.jar


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.4

How reproducible:
Always

Steps to Reproduce:
1. Start eclipse.
  

Actual Results:  1. SDK is being loaded. (SDK progress is shown)
2. SDK progress disappears.
3. jvm error displayed.
4. Hang.

Expected Results:  1. eclipse...

Additional info:

RPM versions:
rpm -qa --queryformat="%{name}-%{version}-%{arch}\n" | egrep "gcj|gcc|eclipse" | sort
compat-libgcc-296-2.96-i386
eclipse-bugzilla-0.1.0_fc-x86_64
eclipse-cdt-3.0.0_fc-x86_64
eclipse-changelog-2.0.1_fc-x86_64
eclipse-ecj-3.1.1-x86_64
eclipse-jdt-3.1.1-x86_64
eclipse-jdt-devel-3.1.1-x86_64
eclipse-pde-3.1.1-x86_64
eclipse-pde-devel-3.1.1-x86_64
eclipse-platform-3.1.1-x86_64
eclipse-platform-devel-3.1.1-x86_64
eclipse-pydev-0.9.3_fc-x86_64
eclipse-rcp-3.1.1-x86_64
gcc-4.0.2-x86_64
gcc-c++-4.0.2-x86_64
gcc-gfortran-4.0.2-x86_64
gcc-java-4.0.2-x86_64
java-1.4.2-gcj-compat-1.4.2.0-x86_64
java-1.4.2-gcj-compat-devel-1.4.2.0-x86_64
libgcc-4.0.2-i386
libgcc-4.0.2-x86_64
libgcj-4.0.2-i386
libgcj-4.0.2-x86_64
libgcj-devel-4.0.2-x86_64
Comment 1 Andrew Overholt 2005-12-22 19:45:14 EST
I think this is a duplicate of bug 174612 which is in turn a manifestation of
gcc bug #13212.  Please see the comments in bug 174612 and note that attempts to
start Eclipse after the initial failed attempt worked for me.  I'm interested to
hear if that's true for everyone.

*** This bug has been marked as a duplicate of 174612 ***

Note You need to log in before you can comment on or make changes to this bug.