Bug 176414 - OpenGL programs stopped to work due to missing visuals
OpenGL programs stopped to work due to missing visuals
Status: CLOSED DUPLICATE of bug 176976
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-12-22 08:51 EST by Pawel Salek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 05:18:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2005-12-22 08:51:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
After recent "yum update", 3D graphics stopped to work with depth 16bpp. Previous update was done more or less one week ago and then everything worked just fine.

Version-Release number of selected component (if applicable):
xorg-x11-drv-sis-0.8.1-1

How reproducible:
Always

Steps to Reproduce:
1. compile attached program and try running it.
2.
3.
  

Actual Results:  freeglut (./surf3d):  ERROR:  Internal error <Visual with necessary capabilities not found> in function fgOpenWindow
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Resource id in failed request:  0x0
  Serial number of failed request:  16
  Current serial number in output stream:  19


Expected Results:  The program should show up the window.

Additional info:
Comment 1 Pawel Salek 2005-12-22 09:47:06 EST
I do not seem to be able to attach any file but it does ot matter. The problem
appears with depth 24bpp as well.
Comment 2 Pawel Salek 2005-12-23 06:20:10 EST
Other OpenGL programs say eg.:
spartan/builder error: unable to find visual to support double buffer, RGB,
Z-buffered rendering.
Comment 3 Pawel Salek 2005-12-24 09:58:32 EST
I have only now noticed some stuff in the log file:
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295

Looks pretty bogus to me. There was a similar report on dri-devel list.
Comment 4 Mike A. Harris 2006-01-31 20:52:51 EST
This problem seems to be getting reported on various hardware, rather than
just SiS.  I've also noticed that it is only getting reported on x86_64.

Adding to FC5Target tracker.

If you discover any additional info or mail postings, please add them to
the report.
Comment 5 Pawel Salek 2006-02-02 05:13:49 EST
Not sure if this is relevant but warnings (not critical errors, fortunately)
about lacking visuals can be seen on other hardware too. My 4years old Xeon with
Matrox G550 and xorg-x11-6.8.2-1.FC3.45.2 prints following whenever I execute an
OpenGL program:
$ ./datavisualiser > log
libGL warning: 3D driver claims to not support visual 0x23
libGL warning: 3D driver claims to not support visual 0x24
libGL warning: 3D driver claims to not support visual 0x27
libGL warning: 3D driver claims to not support visual 0x28
libGL warning: 3D driver claims to not support visual 0x2b
libGL warning: 3D driver claims to not support visual 0x2c
libGL warning: 3D driver claims to not support visual 0x2f
libGL warning: 3D driver claims to not support visual 0x30
I wonder whether the fatal error I see with FC5devel is just the visual removal
pushed one step further.
Comment 6 Mike A. Harris 2006-02-07 05:18:00 EST

*** This bug has been marked as a duplicate of 176976 ***

Note You need to log in before you can comment on or make changes to this bug.