Bug 176421 - Proliant DL380 (cciss disk) hangs at first boot after installation
Proliant DL380 (cciss disk) hangs at first boot after installation
Status: CLOSED DUPLICATE of bug 196628
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: grub (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 10:28 EST by Ole Holm Nielsen
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 14:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ole Holm Nielsen 2005-12-22 10:28:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 CentOS/1.0.7-1.4.1.centos4 Firefox/1.0.7

Description of problem:
A HP Proliant DL380 G3 server was installed with RHEL4 AS Update 2 (was previously
running RHEL3 without any problems).
Boot disk is on Smart Array 5i RAID controller (cciss driver), two 36 GB disks
mirrored RAID 1+0.  Disk partitions: /boot (100MB), / (about 30GB), swap (4095MB).
Installed RHEL4U2 with "Minimal" set of RPMs as a test.
After installation the server should boot for the first time.
When it comes to the boot stage, messages from Grub are expected, but in stead
the screen goes black and nothing happens for hours.  The mirrored
boot disks show continual activity, but nothing happens.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 AS Update 2.
2. First reboot after installation: Machine hangs.

  

Actual Results:  Server hangs in booting forever with a blank screen at the Grub stage.

Expected Results:  A normal boot.

Additional info:

Additional disks added since the upgrade from RHEL3: 
2 logical volumes added on cciss controller, and external RAID box on PCI SCSI-controller with two disk volumes of 996 GB and 1004 GB.
I looked at Bugid #152954 and tried adding acpi=off after the initrd line in grub.conf, but the server still hangs in the same way.
Comment 1 Ole Holm Nielsen 2006-01-06 08:53:12 EST
I removed the external RAID box on PCI SCSI-controller with two disk volumes on
SCSI ID 0, LUNs 0 and 1.  I then reinstalled RHEL from scratch, and now
everything  worked as expected.  I conclude that RHEL4 installation can't handle
SCSI disk devices with multiple LUNs.

I reconnected the external RAID box to the running RHEL4 system, but only the
disk device on LUN 0 is visible as /dev/sda, whereas the device on LUN 1 can't
be found.  So RHEL4 really seems to have problems with multi-LUN disks (?)
Comment 2 Peter Jones 2007-05-01 14:52:02 EDT
This appears to be a duplicate of #196628 .

*** This bug has been marked as a duplicate of 196628 ***

Note You need to log in before you can comment on or make changes to this bug.