Bug 1764227 - Incorrect validation pattern on ConsoleCLIDownloads Href field
Summary: Incorrect validation pattern on ConsoleCLIDownloads Href field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1764224
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-22 13:46 UTC by Samuel Padgett
Modified: 2019-11-13 18:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1764224
Environment:
Last Closed: 2019-11-13 18:56:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 324 'None' 'closed' 'Bug 1764227: Incorrect validation pattern on ConsoleCLIDownloads Href field' 2019-11-19 15:44:59 UTC
Red Hat Product Errata RHBA-2019:3303 None None None 2019-11-13 18:56:13 UTC

Description Samuel Padgett 2019-10-22 13:46:40 UTC
+++ This bug was initially created as a clone of Bug #1764224 +++

Description of problem:
Validation pattern on ConsoleCLIDownloads Href field is to restrictive.

Version-Release number of selected component (if applicable):
4.3.0-0.ci-2019-10-21-030544

How reproducible:
Always

Steps to Reproduce:
1. Go to `/k8s/cluster/console.openshift.io~v1~ConsoleCLIDownload/~new`
2. Add trailing slash to the `href` field
3. 

Actual results:
Error will ocurre:
Error "Invalid value: "": spec.links.href in body should match '^https://([\w-]+.)+[\w-]+(/[\w- ./?%&=])?$'" for field "spec.links.href".

Expected results:
CR will be created

Additional info:

Comment 2 XiaochuanWang 2019-10-28 07:21:50 UTC
Check with 'https://www.example.com/' and it does successfully saved, the actual download link on page after created will remove the trailing slash.
This could be Verified.
Tested on 4.2.0-0.nightly-2019-10-27-140004

Comment 4 errata-xmlrpc 2019-11-13 18:56:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3303


Note You need to log in before you can comment on or make changes to this bug.