Bug 1764236 - neovim in diff mode doesn't draw itself correctly in gnome-terminal
Summary: neovim in diff mode doesn't draw itself correctly in gnome-terminal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: neovim
Version: 31
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-22 13:59 UTC by Leonid Podolny
Modified: 2019-10-31 00:58 UTC (History)
6 users (show)

Fixed In Version: neovim-0.4.2-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-31 00:58:27 UTC


Attachments (Terms of Use)
Screenshot (271.89 KB, image/png)
2019-10-22 13:59 UTC, Leonid Podolny
no flags Details

Description Leonid Podolny 2019-10-22 13:59:33 UTC
Created attachment 1628025 [details]
Screenshot

Description of problem:


Version-Release number of selected component (if applicable):

neovim-0.4.2-1.fc31.x86_64
gnome-terminal-3.34.1-1.fc31.x86_64
xfce4-terminal-0.8.8-2.fc31.x86_64
vte291-0.58.1-1.fc31.x86_64
Gnome 3.34

How reproducible:
Always

Steps to Reproduce:
1. Find two files that have differences with enough distance between them not to fit on one screen.
2. `nvim -f -d file1 file2`
3. Press `]c` to jump from the first difference to anotherm while redrawing the entire screen.

Actual results:
The window is garbled (attaching screenshot).

Expected results:
The window isn't garbled.

Additional info:
This reproduces in gnome-terminal, xfce4-terminal, but not in xterm and rxvt, so the problem is somewhere between neovim, vte and the new gnome, but I can't determine which of them is actually guilty. Please reassign if the component is wrong.

Comment 1 Andreas Schneider 2019-10-23 10:09:46 UTC
Could you report this issue upstream please?

https://github.com/neovim/neovim/issues

Comment 2 Leonid Podolny 2019-10-23 14:04:24 UTC
Thank you for your response -- just did: https://github.com/neovim/neovim/issues/11278

Curiously, the problem doesn't reproduce with the latest nightly build, but does reproduce with their build of 0.4.2, so it appears like it was fixed.

Comment 3 Fedora Update System 2019-10-29 09:25:20 UTC
FEDORA-2019-a358634f66 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a358634f66

Comment 4 Fedora Update System 2019-10-30 01:29:43 UTC
neovim-0.4.2-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a358634f66

Comment 5 Fedora Update System 2019-10-31 00:58:27 UTC
neovim-0.4.2-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.