Bug 176486 - [PATCH] Add a do-not-fork option; fix uninitialised variables
[PATCH] Add a do-not-fork option; fix uninitialised variables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-23 05:39 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-23 08:28:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds '-n' do-not-fork option (2.42 KB, patch)
2005-12-23 05:39 EST, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2005-12-23 05:39:06 EST
Description of problem:

* added support for a '-n' (do-not-fork) option so that 'atd' works
  better with advanced init methods like initng or minit

* daemon.c: initialized daemon_debug to zero; afais, this non-static
  variable will never be initialized and works only because of certain
  constraints in the environment (BSS section will be zeroed by default;
  can break with '-fno-zero-initialized-in-bss')


Version-Release number of selected component (if applicable):

at-3.1.8-78_FC4
Comment 1 Enrico Scholz 2005-12-23 05:39:06 EST
Created attachment 122559 [details]
Adds '-n' do-not-fork option
Comment 2 Jason Vas Dias 2006-01-12 16:53:40 EST
OK, I'll put this in the next release, whenever that is - I don't think this
"problem" is of sufficient importance to warrant a respin on its own account.
Comment 3 Marcela Mašláňová 2006-08-23 08:28:04 EDT
I put it in rawhide. I think it's not important for an update.

Note You need to log in before you can comment on or make changes to this bug.