Bug 176494 - last -i returns strange IP addresses
last -i returns strange IP addresses
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-12-23 11:41 EST by Mike Jang
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 05:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Jang 2005-12-23 11:41:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
On my 64-bit system, running FC5 test1, I get a wild variety of IP addresses for logins, per last -i output. Does not happen on my 32-bit system running FC5 test1, or my Ubuntu breezy system, both on the same network.

Version-Release number of selected component (if applicable):
SysVinit-2.85-42

How reproducible:
Always

Steps to Reproduce:
1.last -i
2.Also appears when I run utmpdump /var/log/wtmp
3.
  

Actual Results:  Lots of strange IP addresses, including from impossible locations, e.g. from external networks during the boot and shutdown process. If I were being hacked, I'd think I'd get a similar result on my 32-bit system running FC5 test1.

Expected Results:  IP address output from last -i should be 0.0.0.0 unless I log in from another system.

Additional info:

When I run last -i, I get entries like:

michael  pts/2        254.107.2.0      Fri Dec 16 12:44 - down   (13:23)
michael  pts/1        19.130.3.0       Fri Dec 16 12:41 - down   (13:26)
michael  pts/1        201.242.9.0      Fri Dec 16 12:30 - 12:41  (00:10)
michael  :0           0.0.0.0          Fri Dec 16 12:28 - down   (13:39)
reboot   system boot  120.225.6.0      Fri Dec 16 12:25          (13:42)
reboot   system boot  155.253.0.0      Fri Dec 16 00:54          (01:10)

Seems reminiscient of bug 82540, but I don't see this problem on my other FC5 test1 system running on a 32-bit laptop.
Comment 1 Rahul Sundaram 2006-02-20 05:41:06 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Bill Nottingham 2006-08-09 19:54:23 EDT
This isn't actually a last bug; programs are putting junk in the file due to a
32/64-bit problem.

reboot/init is one of them; this is fixed in SysVinit-2.86-9 or later. 

Assigning to util-linux for the other part of the fix.
Comment 3 Karel Zak 2006-08-10 05:48:50 EDT
Thanks. Fixed in util-linux-2.13-0.37 or later.

Note You need to log in before you can comment on or make changes to this bug.