Bug 176500 - Missing BuildRequires
Missing BuildRequires
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: classpathx-jaf (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-23 13:45 EST by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 10:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2005-12-23 13:45:25 EST
The spec file is missing:

BuildRequires: gcc-java
Comment 1 Gary Benson 2006-01-03 03:42:42 EST
Or at least java-devel.  Well spotted!
Comment 2 Fernando Nasser 2006-01-03 10:27:40 EST
Well, BuildRequiring 'java-devel' was not a common practice in JPP.  It is an
upstream practice and we don't change upstream practices when importing (thus
this bug is being closed -- Gary, feel free to handle it differently for Fedora
only).  There is a bug repository at JPackage.org where we can ask for these
policies to be changed, and there is where such a bug should be filed and fixed.
 However, in this case I have a way to get things in motion...

It seems that this is due to historical reasons, so I will give a due warning to
the upstream JPP community and add a BuildRequires 'java-devel' to the packages
in the next JPP generation, JPP 1.7.  They will eventually migrate into our
released SRPMs as we adopt JPP 1.7 later this year.

For reference, the text, from 'nim' that explains the upstream reasons.

I think from now on most specs should include a java-devel
buildrequires and a java or java-devel requires (the only reason we didn't
do it before was because some people, Ville among them needed to install
upstream jvm packages but that should have been fixed by Ville's -compat
jvm package). I can imagine there are quite a lot of packages that still
have missing deps but these are problems that should be fixed over time.
 -- Nicolas Mailhot

Note You need to log in before you can comment on or make changes to this bug.