Bug 1765015 - Resources Tab under Custom Resource details page for installed operator does not list StorageClass
Summary: Resources Tab under Custom Resource details page for installed operator does ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: umanga
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-24 07:25 UTC by umanga
Modified: 2020-01-23 11:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:09:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
404 not found under resources (39.55 KB, image/png)
2019-10-24 07:25 UTC, umanga
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3143 None closed Bug 1765009: Use full GroupVersionKind when necessary for operand resources 2020-02-13 21:11:17 UTC
Github openshift console pull 3171 None closed Bug 1765015: Correctly handle cluster-scoped resource links for operand resources 2020-02-13 21:11:17 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:09:34 UTC

Description umanga 2019-10-24 07:25:39 UTC
Created attachment 1628739 [details]
404 not found under resources

Description of problem:
Resources Tab under Custom Resource details page for installed operator does not list StorageClass. Instead, it gives a 404 Not Found.

This is because the api request fails.
Request URL: https://console-openshift-console.apps.uchapaga-oct23.devcluster.openshift.com/api/kubernetes/apis/storage.k8s.io/v1/namespaces/openshift-storage/storageclasses?limit=250

We need to use,
https://console-openshift-console.apps.uchapaga-oct23.devcluster.openshift.com/api/kubernetes/apis/storage.k8s.io/v1/storageclasses?limit=250
to make request as StorageClass is not namespaced.

Version-Release number of selected component (if applicable):
OCP 4.2.0

How reproducible:
100%

Steps to Reproduce:
1. Deploy operator
2. Create a CustomResource that owns a StorageClass
3. Check the Resource Tab for that CustomResource 

Actual results:
404 Not Found

Expected results:
List of StorageClass owned.

Additional info:

Comment 1 Samuel Padgett 2019-10-24 12:58:44 UTC
It looks like we're not properly handling cluster scoped resources.

Comment 2 Cyril 2019-10-25 17:25:32 UTC
I need help reproducing Bug 1765015. Tried to install OCS but couldn't find it in the Operator Hub.

Comment 3 umanga 2019-10-29 06:27:33 UTC
(In reply to Cyril from comment #2)
> I need help reproducing Bug 1765015. Tried to install OCS but couldn't find
> it in the Operator Hub.

Provided a setup with error reproduced (via private chat).

Comment 4 Samuel Padgett 2019-10-30 19:19:16 UTC
I'm going to duplicate this to bug 1765009. These are different symptoms of the same basic problem.

*** This bug has been marked as a duplicate of bug 1765009 ***

Comment 5 Samuel Padgett 2019-10-31 12:23:39 UTC
Removing as a duplicate since there is an additional fix needed for storage classes to work.

Comment 7 Yadan Pei 2019-11-07 05:51:15 UTC
Umanga, can you help verify the fix? I still can't get a successful OCS operator even using release-4.2 branch.

Thank you for your help

Comment 8 umanga 2019-11-07 06:54:14 UTC
Tested with OCP 4.3.0-0.ci-2019-11-07-022944. I can see the StorageClass getting listed correctly.
Attaching a screenshot and marking this as verified.

Comment 10 Yadan Pei 2019-11-07 08:09:39 UTC
Thank you very much, umanga

Comment 12 errata-xmlrpc 2020-01-23 11:09:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.