Bug 1765068 - The baremetal host counter in the inventory card is not updating
Summary: The baremetal host counter in the inventory card is not updating
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.3.0
Assignee: Honza Pokorny
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-24 09:50 UTC by Udi
Modified: 2020-01-23 11:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:09:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3291 0 'None' 'closed' 'Bug 1765068: Make optional resources optional in inventory card' 2019-11-19 09:09:31 UTC
Github openshift console pull 3292 0 'None' 'closed' 'Bug 1765068: [metal3] Make maintenance optional in inventory item' 2019-11-19 09:09:31 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:09:34 UTC

Description Udi 2019-10-24 09:50:01 UTC
Description of problem:
In the inventory card in the systems dashboards, the counter for the baremetal hosts remains a gray fading square


Version-Release number of selected component (if applicable):
4.3.0-0.okd-2019-10-23-224431


How reproducible:
100%


Steps to Reproduce:
1. Open the dashboards page and look at the last line in the inventory card


Actual results:
It says: [] Bare Metal Hosts


Expected results:
It should say: 3 Bare Metal Hosts


Additional info:
No relevant errors seem to be found in the browser console. There are some websocket connection errors and some svg errors.

Comment 1 Honza Pokorny 2019-11-06 19:24:52 UTC
I can reproduce this error in my cluster.  The bug is caused by the absence of the node maintenance CRD/operator.  The inventory card waits for the maintenance data to arrive and it never does.

Comment 2 Honza Pokorny 2019-11-07 13:48:43 UTC
After installing HCO in the cluster, this works as expected.

Comment 3 Jiri Tomasek 2019-11-07 16:34:46 UTC
This is a problem, we can't rely on the presence of that node maintenance operator. The BaremetalHost inventory item should treat the maintenance as optional. There is an 'optional': boolean on FirehoseResource which we could use. Optional resources should not be taken into account when isLoading InventoryItem prop is calculated in InventoryCard. IMHO we should filter optional resources when additionalResourcesLoaded is calculated here https://github.com/openshift/console/blob/master/frontend/public/components/dashboard/dashboards-page/overview-dashboard/inventory-card.tsx#L75

Comment 7 errata-xmlrpc 2020-01-23 11:09:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.