Bug 1765106 - ipa-server-install is failing with ipapython.admintool: ERROR failed to create DS instance Command
Summary: ipa-server-install is failing with ipapython.admintool: ERROR failed to cr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
: 1763408 1766386 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-24 11:01 UTC by anuja
Modified: 2020-03-31 19:46 UTC (History)
8 users (show)

Fixed In Version: 389-ds-base-1.3.10.1-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-31 19:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1064 None None None 2020-03-31 19:46:55 UTC

Description anuja 2019-10-24 11:01:24 UTC
Description of problem:
ipa-server-install is failing with error:
  [1/45]: creating directory server instance
  [error] RuntimeError: failed to create DS instance Command '/usr/sbin/setup-ds.pl --silent --logfile - -f /tmp/tmp079THL' returned non-zero exit status 1
ipapython.admintool: ERROR    failed to create DS instance Command '/usr/sbin/setup-ds.pl --silent --logfile - -f /tmp/tmp079THL' returned non-zero exit status 1
ipapython.admintool: ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information


Version-Release number of selected component (if applicable):
389-ds-base.x86_64 0:1.3.10.1-3.el7
ipa-server-4.6.6-8.el7.x86_64  

Steps to Reproduce:
1. ipa-server-install --setup-dns  --auto-forwarders --auto-reverse --hostname=ipaserver.ipa.test -r IPA.TEST -n ipa.test -p Password123 -a Password123 --allow-zone-overlap --ip-address= -U

Actual results:
The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)
  * Configure the KDC to enable PKINIT

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host ipaqavmd.testrelm.test
Checking DNS domain testrelm.test., please wait ...
Checking DNS forwarders, please wait ...

The IPA Master Server will be configured with:
......
......
......
Forward policy:   only
Reverse zone(s):  No reverse zone

Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv). Estimated time: 30 seconds
  [1/45]: creating directory server instance
  [error] RuntimeError: failed to create DS instance Command '/usr/sbin/setup-ds.pl --silent --logfile - -f /tmp/tmp079THL' returned non-zero exit status 1
ipapython.admintool: ERROR    failed to create DS instance Command '/usr/sbin/setup-ds.pl --silent --logfile - -f /tmp/tmp079THL' returned non-zero exit status 1


Expected results:
ipa server should be installed successfully.

Additional info:

Comment 9 mreynolds 2019-10-29 15:00:12 UTC
*** Bug 1763408 has been marked as a duplicate of this bug. ***

Comment 12 Viktor Ashirov 2019-11-01 08:35:00 UTC
*** Bug 1763408 has been marked as a duplicate of this bug. ***

Comment 13 anuja 2019-11-06 11:31:40 UTC
Verified using :
389-ds-base-1.3.10.1-4.el7
ipa-server-4.6.6-9.el7.x86_64

Console log using existing automation :  

:: [ 06:12:53 ] :: [   PASS   ] :: Command ' /usr/sbin/ipa-server-install --setup-dns  --auto-forwarders --auto-reverse --hostname=qe-17.relm.test -r RELM.TEST -n relm.test -p Secret123 -a Secret123 --allow-zone-overlap --ip-address=x.x.x.x -U' (Expected 0, got 0)
:: [ 06:12:56 ] :: [  BEGIN   ] :: Running 'ipactl stop'
ipa: INFO: The ipactl command was successful
Stopping ipa-dnskeysyncd Service
Stopping ipa-otpd Service
Stopping pki-tomcatd Service
Stopping ntpd Service
Stopping ipa-custodia Service
Stopping httpd Service
Stopping named Service
Stopping kadmin Service
Stopping krb5kdc Service
Stopping Directory Service
:: [ 06:13:02 ] :: [   PASS   ] :: Command 'ipactl stop' (Expected 0, got 0)
:: [ 06:13:02 ] :: [  BEGIN   ] :: Running 'ipactl start'
ipa: INFO: The ipactl command was successful
Starting Directory Service
Starting krb5kdc Service
Starting kadmin Service
Starting named Service
Starting httpd Service
Starting ipa-custodia Service
Starting ntpd Service
Starting pki-tomcatd Service
Starting ipa-otpd Service
Starting ipa-dnskeysyncd Service
:: [ 06:13:19 ] :: [   PASS   ] :: Command 'ipactl start' (Expected 0, got 0)

Based on this marking bz as verified.

Comment 14 Viktor Ashirov 2019-11-18 20:12:13 UTC
*** Bug 1766386 has been marked as a duplicate of this bug. ***

Comment 16 errata-xmlrpc 2020-03-31 19:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1064


Note You need to log in before you can comment on or make changes to this bug.