Bug 1765110 - fatal: [ceph-0]: FAILED The conditional check failed. Unexpected templating type error occurred
Summary: fatal: [ceph-0]: FAILED The conditional check failed. Unexpected templating t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z1
: 3.3
Assignee: Dimitri Savineau
QA Contact: Nathan Weinberg
URL:
Whiteboard:
: 1766185 (view as bug list)
Depends On:
Blocks: 1578730
TreeView+ depends on / blocked
 
Reported: 2019-10-24 11:30 UTC by Filip Hubík
Modified: 2019-11-08 16:14 UTC (History)
13 users (show)

Fixed In Version: ceph-ansible-3.2.30.1-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-08 16:14:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
ceph_ansible_command.log (694.63 KB, text/plain)
2019-10-24 11:43 UTC, Filip Hubík
no flags Details
ceph-ansible.tar.xz (43.71 KB, application/x-xz)
2019-10-24 11:55 UTC, Giulio Fidente
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4664 0 'None' closed openstack_config: fix docker exec command 2020-12-02 18:52:34 UTC
Red Hat Product Errata RHBA-2019:3815 0 None None None 2019-11-08 16:14:09 UTC

Description Filip Hubík 2019-10-24 11:30:26 UTC
Description of problem:

Overcloud deployment fails on ceph-ansible with error:

$ cat /var/lib/mistral/overcloud/ceph_ansible/ceph_ansible_command.log
...
TASK [ceph-osd : include openstack_config.yml] *********************************
task path: /usr/share/ceph-ansible/roles/ceph-osd/tasks/main.yml:109
Thursday 24 October 2019  05:14:25 -0400 (0:00:00.094)       0:03:30.810 ****** 
included: /usr/share/ceph-ansible/roles/ceph-osd/tasks/openstack_config.yml for ceph-0
TASK [ceph-osd : wait for all osd to be up] ************************************
task path: /usr/share/ceph-ansible/roles/ceph-osd/tasks/openstack_config.yml:2
Thursday 24 October 2019  05:14:25 -0400 (0:00:00.267)       0:03:31.078 ****** 
fatal: [ceph-0]: FAILED! => {"msg": "The conditional check '(wait_for_all_osds_up.stdout | from_json)[\"osdmap\"][\"osdmap\"][\"num_osds\"] | int > 0' failed. The error was: Unexpected templating type error occurred on ({% if (wait_for_all_osds_up.stdout | from_json)[\"osdmap\"][\"osdmap\"][\"num_osds\"] | int > 0 %} True {% else %} False {% endif %}): expected string or buffer"}
NO MORE HOSTS LEFT *************************************************************
PLAY RECAP *********************************************************************
ceph-0                     : ok=94   changed=14   unreachable=0    failed=1   
compute-0                  : ok=9    changed=1    unreachable=0    failed=0   
controller-0               : ok=171  changed=26   unreachable=0    failed=0   
INSTALLER STATUS ***************************************************************
Install Ceph Monitor        : Complete (0:01:00)
Install Ceph Manager        : Complete (0:00:42)
Install Ceph OSD            : In Progress (0:01:17)
    This phase can be restarted by running: roles/ceph-osd/tasks/main.yml
Thursday 24 October 2019  05:14:26 -0400 (0:00:00.238)       0:03:31.316 ****** 
===============================================================================

Version-Release number of selected component (if applicable):
OSP14, puddle 2019-10-21.1

Additional info:
ceph-ansible.noarch  3.2.30-1.el7cp

Comment 2 Filip Hubík 2019-10-24 11:43:04 UTC
Created attachment 1628822 [details]
ceph_ansible_command.log

Comment 3 Giulio Fidente 2019-10-24 11:55:09 UTC
Created attachment 1628824 [details]
ceph-ansible.tar.xz

ceph-ansible ansible log, inventory and group_vars

Comment 11 Giulio Fidente 2019-10-28 14:31:48 UTC
*** Bug 1766185 has been marked as a duplicate of this bug. ***

Comment 21 errata-xmlrpc 2019-11-08 16:14:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3815


Note You need to log in before you can comment on or make changes to this bug.