Bug 176517 - kudzu appears to "forget" about my floppy drive
Summary: kudzu appears to "forget" about my floppy drive
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-24 00:09 UTC by Michal Jaegermann
Modified: 2015-01-04 22:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 04:44:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2005-12-24 00:09:28 UTC
Description of problem:

After recent series of updates, and kudzu seems to be the most likely
candidate unless avahi update to 0.6.1-3 has something to with it but
I cannot see how, my floppy drive does not show up anymore and is absent
from /etc/fstab rewritten by fstab-sync. CD drive is still there for some
reason.

If I will do an explicit modprobe floppy' then hal will  notice it, /etc/fstab
is updated accordingly and floppy is mountable again.  No such workarounds
were required previously.  This does not depend on which of few kernels
I am booting.

I have hal-0.5.5.1-2.1 installed on "11 Dec 2005 11:38:46 AM MST" and I believe
that I would observe if that update would be responsible for what is happening.

Version-Release number of selected component (if applicable):
kudzu-1.2.16-1

How reproducible:
always

Comment 1 Bill Nottingham 2006-01-06 19:25:31 UTC
Does it correspond with a udev update, out of curiousity?

Comment 2 Michal Jaegermann 2006-01-06 21:02:23 UTC
> Does it correspond with a udev update, out of curiousity?

I cannot exclude that.  Things do change very fast.  An update to udev-078-2
happended on 2005-12-22 but it is possible that I did not notice that floppy is
gone until the next day.  In the meantime udev went up to 078-3 on 2005-12-26
and kudzu to 1.2.17-1 on 2006-01-04 but this did not change anything.

Recent changes to hal-0.5.5.1.cvs20060105-2 mean that floppy is not mountable
anymore even after 'modprobe floppy'.  Although a floppy icon shows up in
a "Computer" window there is no floppy entry in /etc/fstab anymore,
as fstab-sync is gone, so clicking on that icon only generates error messages.


Comment 3 Bill Nottingham 2006-01-06 21:41:38 UTC
What do you have in /proc/driver/nvram, if anything? (you may need toload the
nvram module)

Comment 4 Michal Jaegermann 2006-01-06 23:18:20 UTC
> What do you have in /proc/driver/nvram, if anything?

There is no /proc/driver/nvram.

> you may need to load the nvram module

Such module does not exist in rawhide kernels (although it shows up on FC4).

   cat /usr/src/kernels/$(uname -r)/include/config/nvram.h

produces '#undef CONFIG_NVRAM' - so it looks like that this is on purpose.


Comment 5 Bill Nottingham 2006-01-06 23:28:15 UTC
x86_64, I presume?

udev bases loading the floppy driver off of the contents of /proc/driver/nvram,
which expects the nvram module to be around.

Punting to kernel for the moment, although I suppose this could end up in udev's
court.

Comment 6 Michal Jaegermann 2006-01-06 23:50:04 UTC
> x86_64, I presume?

Yes, indeed.  So udev works or does not depending on an architecture?  Nice!

Comment 7 Bill Nottingham 2006-01-07 04:39:17 UTC
x86_64 has no nvram module ATM.

Comment 8 Dave Jones 2006-01-12 04:44:25 UTC
fixed in current builds



Note You need to log in before you can comment on or make changes to this bug.