Bug 176520 - Move from Kernel 2.6.14-1.1644_FC4 to kernel-2.6.14-1.1653_FC4 causes ACPI hang on boot
Summary: Move from Kernel 2.6.14-1.1644_FC4 to kernel-2.6.14-1.1653_FC4 causes ACPI ha...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FCMETA_ACPI
TreeView+ depends on / blocked
 
Reported: 2005-12-24 02:22 UTC by Pat Gunn
Modified: 2015-01-04 22:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-30 01:13:11 UTC
Type: ---


Attachments (Terms of Use)
dmesg of the previous kernel that boots ok (13.57 KB, text/plain)
2005-12-24 02:24 UTC, Pat Gunn
no flags Details

Description Pat Gunn 2005-12-24 02:22:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
All FC4 x86_64 kernels prior to kernel-2.6.14-1.1653_FC4 boot ok, but the update to kernel-2.6.14-1.1653_FC4 causes the system to hang on boot after printing:

ACPI: Subsystem revision 20050916

According to the immediately preceding kernel that I'm using presently, I'm using ACPI Subsystem revision 20050902 successfully. System is a HP Pavilion dv8000z.

Please find attached a dmesg from the last working kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1653_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot with new kernel
2. Cry

Actual Results:  System hangs during bootup

Expected Results:  Successful boot

Additional info:

Comment 1 Pat Gunn 2005-12-24 02:24:50 UTC
Created attachment 122568 [details]
dmesg of the previous kernel that boots ok

Comment 2 Dave Jones 2005-12-24 03:31:45 UTC
can you try the test kernel at http://people.redhat.com/davej/kernels/Fedora/FC4
please ?


Comment 3 Pat Gunn 2005-12-24 03:49:20 UTC
That works. I hope it's released soon -- I can't actually use this kernel daily
because I use livna's ndiswrapper package, and they don't release that package
except for known fedora kernels, meaning wireless will not work, but this kernel
does boot ok. I notice that your fix was just to mix the old ACPI back in
though. I'm hoping that either this is an acceptable strategy, or that the next
version of the ACPI subsystem after this version will not hang. I'll be happy to
test more kernels if you like.

Comment 4 Dave Jones 2005-12-24 04:24:53 UTC
I reported some regressions with the acpi update to the upstream maintainers,
hopefully they'll get worked out before they end up being merged into Linus' tree.



Note You need to log in before you can comment on or make changes to this bug.