Bug 1765249 - Cluster Loader fails when called without configuration (4.2.z)
Summary: Cluster Loader fails when called without configuration (4.2.z)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Loader
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Sebastian Jug
QA Contact: Walid A.
URL:
Whiteboard:
Depends On: 1761925
Blocks: 1741138
TreeView+ depends on / blocked
 
Reported: 2019-10-24 15:42 UTC by Sebastian Jug
Modified: 2020-02-24 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-24 16:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24127 0 None closed Bug 1765249: CL fix fixture path & update config path, quickstarts & bindata 2020-11-17 16:45:03 UTC
Red Hat Product Errata RHBA-2020:0460 0 None None None 2020-02-24 16:52:59 UTC

Description Sebastian Jug 2019-10-24 15:42:36 UTC
This is a duplicate bug of https://bugzilla.redhat.com/show_bug.cgi?id=1761925 for the 4.2.z target

Description of problem:
Cluster Loader is a scale test tool (https://docs.openshift.com/container-platform/4.1/scalability_and_performance/using-cluster-loader.html#running_cluster_loader_)

When running it without specifying user provided configuration, it does not successfully locate the built in test templates.


Version-Release number of selected component (if applicable):
4.2


How reproducible:
Always


Steps to Reproduce:
1.sudo podman run -v ${LOCAL_KUBECONFIG}:/root/.kube/config -i
quay.io/openshift/origin-tests:4.1 /bin/bash -c 'export KUBECONFIG=/root/.kube/config && openshift-tests run-test "[Feature:Performance][Serial][Slow] Load cluster should load the cluster [Suite:openshift]"'
2. Fail


Actual results:
Error stating unable to find template files in built in config.


Expected results:
Succesful execution of built in config by deploying test data templates.


Additional info:
[jugs@trip ~]$ sudo podman run -v /home/jugs/.kube/config:/root/.kube/config:z -i quay.io/openshift/origin-tests:4.2 /bin/bash -c 'export KUBECONFIG=/root/.kube/config && \
openshift-tests run-test "[Feature:Performance][Serial][Slow] Load cluster should load the \
cluster [Suite:openshift]"'
I1016 14:13:00.006474       7 test.go:182] openshift-tests excluded test regex is "\\[Disabled:|\\[Disruptive\\]|\\[Skipped\\]|\\[Slow\\]|\\[Flaky\\]|\\[local\\]|\\[Suite:openshift/test-cmd\\]|\\[Skipped:skeleton\\]|\\[Skipped:Network/OpenShiftSDN\\]"
Oct 16 14:13:00.134: INFO: >>> kubeConfig: /root/.kube/config
Oct 16 14:13:00.137: INFO: Waiting up to 30m0s for all (but 100) nodes to be schedulable
Oct 16 14:13:01.045: INFO: Waiting up to 10m0s for all pods (need at least 0) in namespace 'kube-system' to be running and ready
Oct 16 14:13:01.316: INFO: 0 / 0 pods in namespace 'kube-system' are running and ready (0 seconds elapsed)
Oct 16 14:13:01.316: INFO: expected 0 pod replicas in namespace 'kube-system', 0 are Running and Ready.
Oct 16 14:13:01.316: INFO: Waiting up to 5m0s for all daemonsets in namespace 'kube-system' to start
Oct 16 14:13:01.405: INFO: e2e test version: v1.14.6+bad6c07
Oct 16 14:13:01.487: INFO: kube-apiserver version: v1.14.6+bebfa64
[BeforeEach] [Top Level]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/test.go:59
[BeforeEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:149
STEP: Creating a kubernetes client
Oct 16 14:13:01.488: INFO: >>> kubeConfig: /root/.kube/config
[BeforeEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cluster/cl.go:44
Oct 16 14:13:01.494: INFO: Undefined config file, using built-in config /tmp/fixture-testdata-dir318529024/test/extended/testdata/cluster/master-vert.yaml

[It] should load the cluster [Suite:openshift]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cluster/cl.go:65
Oct 16 14:13:01.495: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Oct 16 14:13:01.585: INFO: Project clusterloader-cakephp-mysql0 does not exist.
Oct 16 14:13:01.585: INFO: Configuration requested deletion of project clusterloader-cakephp-mysql0
Oct 16 14:13:01.585: INFO: Running 'oc --namespace= --config= adm new-project clusterloader-cakephp-mysql0'
Created project clusterloader-cakephp-mysql0
Oct 16 14:13:02.249: INFO: 1/1 : Created new namespace: clusterloader-cakephp-mysql0
[AfterEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/client.go:120
[AfterEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:150
Oct 16 14:13:02.252: INFO: Waiting up to 3m0s for all (but 100) nodes to be ready
Oct 16 14:13:02.505: INFO: Running AfterSuite actions on all nodes
Oct 16 14:13:02.505: INFO: Running AfterSuite actions on node 1
fail [github.com/openshift/origin/test/extended/cluster/cl.go:156]: Unexpected error:
    <*errors.errorString | 0xc00281f110>: {
        s: "unable to find pod/template file ./test/extended/testdata/cluster/quickstarts/cakephp-mysql.json\n",
    }
    unable to find pod/template file ./test/extended/testdata/cluster/quickstarts/cakephp-mysql.json

occurred

Comment 1 Walid A. 2020-01-17 18:49:41 UTC
Tested this on OCP 4.2.15, still getting the same error "unable to find pod/template file ./test/extended/testdata/cluster/quickstarts/cakephp-mysql.json":

# export LOCAL_KUBECONFIG=/root/.kube/config

# podman pull registry.svc.ci.openshift.org/ocp/4.2:tests
Trying to pull registry.svc.ci.openshift.org/ocp/4.2:tests...Getting image source signatures
Copying blob ea010ca18e6c skipped: already exists
Copying blob 1d2c4ce43b78 skipped: already exists
Copying blob 47f81868b940 skipped: already exists
Copying blob 095a39933bb6 skipped: already exists
Copying blob 888af1292700 skipped: already exists
Copying blob 1c9f515fc6ab skipped: already exists
Copying config 6043e1685c done
Writing manifest to image destination
Storing signatures
6043e1685cec33009a5ed8cd66568878ce4b771830a0041f458858aafc1dfe08

# podman run -v ${LOCAL_KUBECONFIG}:/root/.kube/config:z -i registry.svc.ci.openshift.org/ocp/4.2:tests /bin/bash -c 'export KUBECONFIG=/root/.kube/config && openshift-tests run-test "[Feature:Performance][Serial][Slow] Load cluster should load the cluster [Suite:openshift]"'
I0117 18:43:18.657633       8 test.go:182] openshift-tests excluded test regex is "\\[Disabled:|\\[Disruptive\\]|\\[Skipped\\]|\\[Slow\\]|\\[Flaky\\]|\\[local\\]|\\[Suite:openshift/test-cmd\\]|\\[Skipped:skeleton\\]|\\[Skipped:Network/OpenShiftSDN\\]"
Jan 17 18:43:18.745: INFO: >>> kubeConfig: /root/.kube/config
Jan 17 18:43:18.747: INFO: Waiting up to 30m0s for all (but 100) nodes to be schedulable
Jan 17 18:43:18.767: INFO: Waiting up to 10m0s for all pods (need at least 0) in namespace 'kube-system' to be running and ready
Jan 17 18:43:18.786: INFO: 0 / 0 pods in namespace 'kube-system' are running and ready (0 seconds elapsed)
Jan 17 18:43:18.786: INFO: expected 0 pod replicas in namespace 'kube-system', 0 are Running and Ready.
Jan 17 18:43:18.786: INFO: Waiting up to 5m0s for all daemonsets in namespace 'kube-system' to start
Jan 17 18:43:18.792: INFO: e2e test version: v1.14.6+45470ca
Jan 17 18:43:18.793: INFO: kube-apiserver version: v1.14.6+301fd98
[BeforeEach] [Top Level]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/test.go:59
[BeforeEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:149
STEP: Creating a kubernetes client
Jan 17 18:43:18.797: INFO: >>> kubeConfig: /root/.kube/config
[BeforeEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cluster/cl.go:44
Jan 17 18:43:18.801: INFO: Undefined config file, using built-in config /tmp/fixture-testdata-dir585011240/test/extended/testdata/cluster/master-vert.yaml

[It] should load the cluster [Suite:openshift]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cluster/cl.go:65
Jan 17 18:43:18.802: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Jan 17 18:43:18.808: INFO: Configuration requested deletion of project clusterloader-cakephp-mysql0
Jan 17 18:43:18.808: INFO: Deleting project clusterloader-cakephp-mysql0 ...
Jan 17 18:43:28.826: INFO: Running 'oc --namespace= --config= adm new-project clusterloader-cakephp-mysql0'
Created project clusterloader-cakephp-mysql0
Jan 17 18:43:28.978: INFO: 1/1 : Created new namespace: clusterloader-cakephp-mysql0
[AfterEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/client.go:120
[AfterEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:150
Jan 17 18:43:28.980: INFO: Waiting up to 3m0s for all (but 100) nodes to be ready
Jan 17 18:43:28.988: INFO: Running AfterSuite actions on all nodes
Jan 17 18:43:28.988: INFO: Running AfterSuite actions on node 1
fail [github.com/openshift/origin/test/extended/cluster/cl.go:156]: Unexpected error:
    <*errors.errorString | 0xc002f9ed20>: {
        s: "unable to find pod/template file ./test/extended/testdata/cluster/quickstarts/cakephp-mysql.json\n",
    }
    unable to find pod/template file ./test/extended/testdata/cluster/quickstarts/cakephp-mysql.json
    
occurred

# oc version
Client Version: openshift-clients-4.2.2-201910250432-8-g98a84c61
Server Version: 4.2.15
Kubernetes Version: v1.14.6+301fd98

# oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.15    True        False         22h     Cluster version is 4.2.15

# oc get co
NAME                                       VERSION   AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.2.15    True        False         False      22h
cloud-credential                           4.2.15    True        False         False      22h
cluster-autoscaler                         4.2.15    True        False         False      22h
console                                    4.2.15    True        False         False      22h
dns                                        4.2.15    True        False         False      22h
image-registry                             4.2.15    True        False         False      22h
ingress                                    4.2.15    True        False         False      22h
insights                                   4.2.15    True        False         False      22h
kube-apiserver                             4.2.15    True        False         False      22h
kube-controller-manager                    4.2.15    True        False         False      22h
kube-scheduler                             4.2.15    True        False         False      22h
machine-api                                4.2.15    True        False         False      22h
machine-config                             4.2.15    True        False         False      22h
marketplace                                4.2.15    True        False         False      22h
monitoring                                 4.2.15    True        False         False      22h
network                                    4.2.15    True        False         False      22h
node-tuning                                4.2.15    True        False         False      22h
openshift-apiserver                        4.2.15    True        False         False      22h
openshift-controller-manager               4.2.15    True        False         False      22h
openshift-samples                          4.2.15    True        False         False      22h
operator-lifecycle-manager                 4.2.15    True        False         False      22h
operator-lifecycle-manager-catalog         4.2.15    True        False         False      22h
operator-lifecycle-manager-packageserver   4.2.15    True        False         False      3h34m
service-ca                                 4.2.15    True        False         False      22h
service-catalog-apiserver                  4.2.15    True        False         False      22h
service-catalog-controller-manager         4.2.15    True        False         False      22h
storage                                    4.2.15    True        False         False      22h
#

Comment 3 Walid A. 2020-02-11 21:16:45 UTC
Verified successfully on OCP 4.2.18

# oc version
Client Version: openshift-clients-4.2.2-201910250432-8-g98a84c61
Server Version: 4.2.18
Kubernetes Version: v1.14.6+f0fa3b6

# sudo podman pull --authfile /root/.docker/config.json registry.svc.ci.openshift.org/ocp/4.2:tests
Trying to pull registry.svc.ci.openshift.org/ocp/4.2:tests...Getting image source signatures
Copying blob 1d2c4ce43b78 skipped: already exists
Copying blob 1c9f515fc6ab skipped: already exists
Copying blob 47f81868b940 skipped: already exists
Copying blob 888af1292700 skipped: already exists
Copying blob 095a39933bb6 skipped: already exists
Copying blob cf3e7ce52ff0 done
Copying config 3711289f04 done
Writing manifest to image destination
Storing signatures
3711289f04194877c3573285f7ad05a96094d54553c39bdc301f057b3d350adb

# export LOCAL_KUBECONFIG=/root/.kube/config

# sudo podman run -v ${LOCAL_KUBECONFIG}:/root/.kube/config:z -i registry.svc.ci.openshift.org/ocp/4.2:tests /bin/bash -c 'export KUBECONFIG=/root/.kube/config && openshift-tests run-test "[Feature:Performance][Serial][Slow] Load cluster should load the cluster [Suite:openshift]"'
I0211 20:47:04.483358       8 test.go:182] openshift-tests excluded test regex is "\\[Disabled:|\\[Disruptive\\]|\\[Skipped\\]|\\[Slow\\]|\\[Flaky\\]|\\[local\\]|\\[Suite:openshift/test-cmd\\]|\\[Skipped:skeleton\\]|\\[Skipped:Network/OpenShiftSDN\\]"
Feb 11 20:47:04.572: INFO: >>> kubeConfig: /root/.kube/config
Feb 11 20:47:04.574: INFO: Waiting up to 30m0s for all (but 100) nodes to be schedulable
Feb 11 20:47:04.597: INFO: Waiting up to 10m0s for all pods (need at least 0) in namespace 'kube-system' to be running and ready
Feb 11 20:47:04.617: INFO: 0 / 0 pods in namespace 'kube-system' are running and ready (0 seconds elapsed)
Feb 11 20:47:04.617: INFO: expected 0 pod replicas in namespace 'kube-system', 0 are Running and Ready.
Feb 11 20:47:04.617: INFO: Waiting up to 5m0s for all daemonsets in namespace 'kube-system' to start
Feb 11 20:47:04.623: INFO: e2e test version: v1.14.6+f6c71da
Feb 11 20:47:04.624: INFO: kube-apiserver version: v1.14.6+f0fa3b6
[BeforeEach] [Top Level]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/test.go:59
[BeforeEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:149
STEP: Creating a kubernetes client
Feb 11 20:47:04.628: INFO: >>> kubeConfig: /root/.kube/config
[BeforeEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cluster/cl.go:44
Feb 11 20:47:04.630: INFO: Undefined config file, using built-in config /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/master-vert.yaml

[It] should load the cluster [Suite:openshift]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cluster/cl.go:66
Feb 11 20:47:04.631: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Feb 11 20:47:04.639: INFO: Project clusterloader-cakephp-mysql0 does not exist.
Feb 11 20:47:04.639: INFO: Configuration requested deletion of project clusterloader-cakephp-mysql0
Feb 11 20:47:04.639: INFO: Running 'oc --namespace= --config= adm new-project clusterloader-cakephp-mysql0'
Created project clusterloader-cakephp-mysql0
Feb 11 20:47:04.759: INFO: 1/1 : Created new namespace: clusterloader-cakephp-mysql0
Feb 11 20:47:04.759: INFO: We're loading file /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/cakephp-mysql.json: 
Feb 11 20:47:04.759: INFO: Template environment variables will not be modified.
Feb 11 20:47:04.759: INFO: args: [-f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/cakephp-mysql.json -p IDENTIFIER=0]
Feb 11 20:47:04.759: INFO: Running 'oc --namespace=clusterloader-cakephp-mysql0 --config= process -f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/cakephp-mysql.json -p IDENTIFIER=0'
Feb 11 20:47:04.870: INFO: Running 'oc --namespace=clusterloader-cakephp-mysql0 --config= create -f /tmp/clusterloader-cakephp-mysql0-config.json'
secret/cakephp-mysql-example created
service/cakephp-mysql-example created
route.route.openshift.io/cakephp-mysql-example created
imagestream.image.openshift.io/cakephp-mysql-example created
buildconfig.build.openshift.io/cakephp-mysql-example created
deploymentconfig.apps.openshift.io/cakephp-mysql-example created
service/mysql created
deploymentconfig.apps.openshift.io/mysql created
Feb 11 20:47:05.087: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Feb 11 20:47:05.094: INFO: Project clusterloader-dancer-mysql0 does not exist.
Feb 11 20:47:05.094: INFO: Configuration requested deletion of project clusterloader-dancer-mysql0
Feb 11 20:47:05.094: INFO: Running 'oc --namespace=clusterloader-cakephp-mysql0 --config= adm new-project clusterloader-dancer-mysql0'
Created project clusterloader-dancer-mysql0
Feb 11 20:47:05.209: INFO: 1/1 : Created new namespace: clusterloader-dancer-mysql0
Feb 11 20:47:05.209: INFO: We're loading file /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/dancer-mysql.json: 
Feb 11 20:47:05.209: INFO: Template environment variables will not be modified.
Feb 11 20:47:05.209: INFO: args: [-f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/dancer-mysql.json -p IDENTIFIER=0]
Feb 11 20:47:05.209: INFO: Running 'oc --namespace=clusterloader-dancer-mysql0 --config= process -f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/dancer-mysql.json -p IDENTIFIER=0'
Feb 11 20:47:05.319: INFO: Running 'oc --namespace=clusterloader-dancer-mysql0 --config= create -f /tmp/clusterloader-dancer-mysql0-config.json'
secret/dancer-mysql-example created
service/dancer-mysql-example created
route.route.openshift.io/dancer-mysql-example created
imagestream.image.openshift.io/dancer-mysql-example created
buildconfig.build.openshift.io/dancer-mysql-example created
deploymentconfig.apps.openshift.io/dancer-mysql-example created
service/database created
deploymentconfig.apps.openshift.io/database created
Feb 11 20:47:05.543: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Feb 11 20:47:05.550: INFO: Project clusterloader-django-postgresql0 does not exist.
Feb 11 20:47:05.550: INFO: Configuration requested deletion of project clusterloader-django-postgresql0
Feb 11 20:47:05.550: INFO: Running 'oc --namespace=clusterloader-dancer-mysql0 --config= adm new-project clusterloader-django-postgresql0'
Created project clusterloader-django-postgresql0
Feb 11 20:47:05.685: INFO: 1/1 : Created new namespace: clusterloader-django-postgresql0
Feb 11 20:47:05.685: INFO: We're loading file /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/django-postgresql.json: 
Feb 11 20:47:05.685: INFO: Template environment variables will not be modified.
Feb 11 20:47:05.685: INFO: args: [-f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/django-postgresql.json -p IDENTIFIER=0]
Feb 11 20:47:05.685: INFO: Running 'oc --namespace=clusterloader-django-postgresql0 --config= process -f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/django-postgresql.json -p IDENTIFIER=0'
Feb 11 20:47:05.800: INFO: Running 'oc --namespace=clusterloader-django-postgresql0 --config= create -f /tmp/clusterloader-django-postgresql0-config.json'
secret/django-psql-example created
service/django-psql-example created
route.route.openshift.io/django-psql-example created
imagestream.image.openshift.io/django-psql-example created
buildconfig.build.openshift.io/django-psql-example created
deploymentconfig.apps.openshift.io/django-psql-example created
service/postgresql created
deploymentconfig.apps.openshift.io/postgresql created
Feb 11 20:47:06.070: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Feb 11 20:47:06.078: INFO: Project clusterloader-nodejs-mongodb0 does not exist.
Feb 11 20:47:06.078: INFO: Configuration requested deletion of project clusterloader-nodejs-mongodb0
Feb 11 20:47:06.078: INFO: Running 'oc --namespace=clusterloader-django-postgresql0 --config= adm new-project clusterloader-nodejs-mongodb0'
Created project clusterloader-nodejs-mongodb0
Feb 11 20:47:06.205: INFO: 1/1 : Created new namespace: clusterloader-nodejs-mongodb0
Feb 11 20:47:06.205: INFO: We're loading file /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/nodejs-mongodb.json: 
Feb 11 20:47:06.205: INFO: Template environment variables will not be modified.
Feb 11 20:47:06.205: INFO: args: [-f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/nodejs-mongodb.json -p IDENTIFIER=0]
Feb 11 20:47:06.205: INFO: Running 'oc --namespace=clusterloader-nodejs-mongodb0 --config= process -f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/nodejs-mongodb.json -p IDENTIFIER=0'
Feb 11 20:47:06.319: INFO: Running 'oc --namespace=clusterloader-nodejs-mongodb0 --config= create -f /tmp/clusterloader-nodejs-mongodb0-config.json'
secret/nodejs-mongodb-example created
service/nodejs-mongodb-example created
route.route.openshift.io/nodejs-mongodb-example created
imagestream.image.openshift.io/nodejs-mongodb-example created
buildconfig.build.openshift.io/nodejs-mongodb-example created
deploymentconfig.apps.openshift.io/nodejs-mongodb-example created
service/mongodb created
deploymentconfig.apps.openshift.io/mongodb created
Feb 11 20:47:06.531: INFO: Our tuning set is: &{default {{5 0s 0s} {0s}} {{0 0s 0s} {0s}}}
Feb 11 20:47:06.540: INFO: Project clusterloader-rails-postgresql0 does not exist.
Feb 11 20:47:06.540: INFO: Configuration requested deletion of project clusterloader-rails-postgresql0
Feb 11 20:47:06.540: INFO: Running 'oc --namespace=clusterloader-nodejs-mongodb0 --config= adm new-project clusterloader-rails-postgresql0'
Created project clusterloader-rails-postgresql0
Feb 11 20:47:06.683: INFO: 1/1 : Created new namespace: clusterloader-rails-postgresql0
Feb 11 20:47:06.683: INFO: We're loading file /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/rails-postgresql.json: 
Feb 11 20:47:06.683: INFO: Template environment variables will not be modified.
Feb 11 20:47:06.683: INFO: args: [-f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/rails-postgresql.json -p IDENTIFIER=0]
Feb 11 20:47:06.683: INFO: Running 'oc --namespace=clusterloader-rails-postgresql0 --config= process -f /tmp/fixture-testdata-dir701993790/test/extended/testdata/cluster/quickstarts/rails-postgresql.json -p IDENTIFIER=0'
Feb 11 20:47:06.805: INFO: Running 'oc --namespace=clusterloader-rails-postgresql0 --config= create -f /tmp/clusterloader-rails-postgresql0-config.json'
secret/rails-postgresql-example created
service/rails-postgresql-example created
route.route.openshift.io/rails-postgresql-example created
imagestream.image.openshift.io/rails-postgresql-example created
buildconfig.build.openshift.io/rails-postgresql-example created
deploymentconfig.apps.openshift.io/rails-postgresql-example created
service/postgresql created
deploymentconfig.apps.openshift.io/postgresql created
Feb 11 20:47:07.060: INFO: Waiting for 1 RCs in namespace clusterloader-cakephp-mysql0
Feb 11 20:47:07.060: INFO: Waiting for RC: mysql-1
Feb 11 20:47:09.084: INFO: Build List: &BuildList{ListMeta:k8s_io_apimachinery_pkg_apis_meta_v1.ListMeta{SelfLink:/apis/build.openshift.io/v1/namespaces/clusterloader-cakephp-mysql0/builds,ResourceVersion:115969,Continue:,},Items:[{{ } {cakephp-mysql-example-1  clusterloader-cakephp-mysql0 /apis/build.openshift.io/v1/namespaces/clusterloader-cakephp-mysql0/builds/cakephp-mysql-example-1 a9966abb-4d0f-11ea-94bc-0a580a82001c 115706 0 2020-02-11 20:47:05 +0000 UTC <nil> <nil> map[app:cakephp-mysql-example buildconfig:cakephp-mysql-example openshift.io/build-config.name:cakephp-mysql-example openshift.io/build.start-policy:Serial template:cakephp-mysql-example] map[openshift.io/build-config.name:cakephp-mysql-example openshift.io/build.number:1 openshift.io/build.pod-name:cakephp-mysql-example-1-build] [{build.openshift.io/v1 BuildConfig cakephp-mysql-example a969f020-4d0f-11ea-94bc-0a580a82001c 0xc004163ccb <nil>}] nil []  []} {{builder {Git nil <nil> GitBuildSource{URI:https://github.com/sclorg/cakephp-ex.git,Ref:,ProxyConfig:ProxyConfig{HTTPProxy:nil,HTTPSProxy:nil,NoProxy:nil,},} []  nil [] []} nil {Source nil &SourceBuildStrategy{From:k8s_io_api_core_v1.ObjectReference{Kind:DockerImage,Namespace:,Name:image-registry.openshift-image-registry.svc:5000/openshift/php@sha256:289ef5852151a1a3ea4fdf2581a86a60ada0719e54a5ddd78f5252742e6d2b8d,UID:,APIVersion:,ResourceVersion:,FieldPath:,},PullSecret:&k8s_io_api_core_v1.LocalObjectReference{Name:builder-dockercfg-f998s,},Env:[{COMPOSER_MIRROR  nil}],Scripts:,Incremental:nil,ForcePull:false,} nil nil} {&ObjectReference{Kind:ImageStreamTag,Namespace:,Name:cakephp-mysql-example:latest,UID:,APIVersion:,ResourceVersion:,FieldPath:,} &LocalObjectReference{Name:builder-dockercfg-f998s,} []} {map[] map[]} {[] [] ./vendor/bin/phpunit} <nil> map[]} [{Image change nil nil &ImageChangeCause{ImageID:image-registry.openshift-image-registry.svc:5000/openshift/php@sha256:289ef5852151a1a3ea4fdf2581a86a60ada0719e54a5ddd78f5252742e6d2b8d,FromRef:&k8s_io_api_core_v1.ObjectReference{Kind:ImageStreamTag,Namespace:openshift,Name:php:7.1,UID:,APIVersion:,ResourceVersion:,FieldPath:,},} nil nil}]} {Pending false   <nil> <nil> 0s image-registry.openshift-image-registry.svc:5000/clusterloader-cakephp-mysql0/cakephp-mysql-example:latest &ObjectReference{Kind:BuildConfig,Namespace:clusterloader-cakephp-mysql0,Name:cakephp-mysql-example,UID:,APIVersion:,ResourceVersion:,FieldPath:,} {nil} [] }}],}
Feb 11 20:47:09.084: INFO: Waiting for build: "cakephp-mysql-example-1"
Feb 11 20:49:45.098: INFO: Build "cakephp-mysql-example-1" completed
Feb 11 20:49:45.109: INFO: Waiting for deployment: "cakephp-mysql-example"
Feb 11 20:49:45.111: INFO: waiting for deploymentconfig clusterloader-cakephp-mysql0/cakephp-mysql-example to be available with version 1

Feb 11 20:51:09.121: INFO: deploymentconfig clusterloader-cakephp-mysql0/cakephp-mysql-example available after 1m24.010092744s
pods: cakephp-mysql-example-1-qr87r

Feb 11 20:51:09.121: INFO: Deployment "cakephp-mysql-example" completed
Feb 11 20:51:09.126: INFO: Waiting for 2 RCs in namespace clusterloader-dancer-mysql0
Feb 11 20:51:09.126: INFO: Waiting for RC: dancer-mysql-example-1
Feb 11 20:51:11.135: INFO: Waiting for RC: database-1
Feb 11 20:51:13.153: INFO: Build List: &BuildList{ListMeta:k8s_io_apimachinery_pkg_apis_meta_v1.ListMeta{SelfLink:/apis/build.openshift.io/v1/namespaces/clusterloader-dancer-mysql0/builds,ResourceVersion:117578,Continue:,},Items:[{{ } {dancer-mysql-example-1  clusterloader-dancer-mysql0 /apis/build.openshift.io/v1/namespaces/clusterloader-dancer-mysql0/builds/dancer-mysql-example-1 a9bf9ac3-4d0f-11ea-b867-0a580a80001f 117374 0 2020-02-11 20:47:05 +0000 UTC <nil> <nil> map[app:dancer-mysql-example buildconfig:dancer-mysql-example openshift.io/build-config.name:dancer-mysql-example openshift.io/build.start-policy:Serial template:dancer-mysql-example] map[openshift.io/build-config.name:dancer-mysql-example openshift.io/build.number:1 openshift.io/build.pod-name:dancer-mysql-example-1-build] [{build.openshift.io/v1 BuildConfig dancer-mysql-example a9adde57-4d0f-11ea-94bc-0a580a82001c 0xc0026a113b <nil>}] nil []  []} {{builder {Git nil <nil> GitBuildSource{URI:https://github.com/sclorg/dancer-ex.git,Ref:,ProxyConfig:ProxyConfig{HTTPProxy:nil,HTTPSProxy:nil,NoProxy:nil,},} []  nil [] []} &SourceRevision{Type:Git,Git:&GitSourceRevision{Commit:96e1791a65027d96707a28035f74c1bee78c2882,Author:SourceControlUser{Name:Honza Horak,Email:hhorak@redhat.com,},Committer:SourceControlUser{Name:GitHub,Email:noreply@github.com,},Message:Merge pull request #75 from liangxia/okd,},} {Source nil &SourceBuildStrategy{From:k8s_io_api_core_v1.ObjectReference{Kind:DockerImage,Namespace:,Name:image-registry.openshift-image-registry.svc:5000/openshift/perl@sha256:4dde5621a54dc0ef542d015b42a9e30d6ed45a185ceec7ae81be5b0da43c9e2c,UID:,APIVersion:,ResourceVersion:,FieldPath:,},PullSecret:&k8s_io_api_core_v1.LocalObjectReference{Name:builder-dockercfg-ks9gs,},Env:[{CPAN_MIRROR  nil}],Scripts:,Incremental:nil,ForcePull:false,} nil nil} {&ObjectReference{Kind:ImageStreamTag,Namespace:,Name:dancer-mysql-example:latest,UID:,APIVersion:,ResourceVersion:,FieldPath:,} &LocalObjectReference{Name:builder-dockercfg-ks9gs,} []} {map[] map[]} {[] [] perl -I extlib/lib/perl5 -I lib t/*} <nil> map[]} [{Image change nil nil &ImageChangeCause{ImageID:image-registry.openshift-image-registry.svc:5000/openshift/perl@sha256:4dde5621a54dc0ef542d015b42a9e30d6ed45a185ceec7ae81be5b0da43c9e2c,FromRef:&k8s_io_api_core_v1.ObjectReference{Kind:ImageStreamTag,Namespace:openshift,Name:perl:5.26,UID:,APIVersion:,ResourceVersion:,FieldPath:,},} nil nil}]} {Complete false   2020-02-11 20:47:05 +0000 UTC 2020-02-11 20:50:45 +0000 UTC 3m40s image-registry.openshift-image-registry.svc:5000/clusterloader-dancer-mysql0/dancer-mysql-example:latest &ObjectReference{Kind:BuildConfig,Namespace:clusterloader-dancer-mysql0,Name:dancer-mysql-example,UID:,APIVersion:,ResourceVersion:,FieldPath:,} {&BuildStatusOutputTo{ImageDigest:sha256:975a885a105241191575320af20a09c19f2cfa9bea68df4b1653d999ad58b298,}} [{FetchInputs 2020-02-11 20:47:23 +0000 UTC 622 [{FetchGitSource 2020-02-11 20:47:23 +0000 UTC 622}]} {PullImages 2020-02-11 20:47:26 +0000 UTC 62587 [{PullBaseImage 2020-02-11 20:47:26 +0000 UTC 62587}]} {Build 2020-02-11 20:48:29 +0000 UTC 131279 [{DockerBuild 2020-02-11 20:48:29 +0000 UTC 131279}]} {PushImage 2020-02-11 20:50:40 +0000 UTC 4531 [{PushImage 2020-02-11 20:50:40 +0000 UTC 4531}]}] }}],}
Feb 11 20:51:13.153: INFO: Waiting for build: "dancer-mysql-example-1"
Feb 11 20:51:19.167: INFO: Build "dancer-mysql-example-1" completed
Feb 11 20:51:19.178: INFO: Waiting for deployment: "dancer-mysql-example"
Feb 11 20:51:19.180: INFO: waiting for deploymentconfig clusterloader-dancer-mysql0/dancer-mysql-example to be available with version 1

Feb 11 20:51:20.190: INFO: deploymentconfig clusterloader-dancer-mysql0/dancer-mysql-example available after 1.009848734s
pods: dancer-mysql-example-1-kb7hd

Feb 11 20:51:20.190: INFO: Deployment "dancer-mysql-example" completed
Feb 11 20:51:20.195: INFO: Waiting for 2 RCs in namespace clusterloader-django-postgresql0
Feb 11 20:51:20.195: INFO: Waiting for RC: django-psql-example-1
Feb 11 20:51:22.203: INFO: Waiting for RC: postgresql-1
Feb 11 20:51:24.223: INFO: Build List: &BuildList{ListMeta:k8s_io_apimachinery_pkg_apis_meta_v1.ListMeta{SelfLink:/apis/build.openshift.io/v1/namespaces/clusterloader-django-postgresql0/builds,ResourceVersion:117651,Continue:,},Items:[{{ } {django-psql-example-1  clusterloader-django-postgresql0 /apis/build.openshift.io/v1/namespaces/clusterloader-django-postgresql0/builds/django-psql-example-1 aa30db1b-4d0f-11ea-b906-0a580a81002a 116610 0 2020-02-11 20:47:06 +0000 UTC <nil> <nil> map[app:django-psql-example buildconfig:django-psql-example openshift.io/build-config.name:django-psql-example openshift.io/build.start-policy:Serial template:django-psql-example] map[openshift.io/build-config.name:django-psql-example openshift.io/build.number:1 openshift.io/build.pod-name:django-psql-example-1-build] [{build.openshift.io/v1 BuildConfig django-psql-example a9fbbcdc-4d0f-11ea-b906-0a580a81002a 0xc0024a867b <nil>}] nil []  []} {{builder {Git nil <nil> GitBuildSource{URI:https://github.com/sclorg/django-ex.git,Ref:,ProxyConfig:ProxyConfig{HTTPProxy:nil,HTTPSProxy:nil,NoProxy:nil,},} []  nil [] []} &SourceRevision{Type:Git,Git:&GitSourceRevision{Commit:090522300f6cfe9476308128684b1624e980df7b,Author:SourceControlUser{Name:Ben Parees,Email:bparees@users.noreply.github.com,},Committer:SourceControlUser{Name:GitHub,Email:noreply@github.com,},Message:Merge pull request #137 from danmcp/patch-1,},} {Source nil &SourceBuildStrategy{From:k8s_io_api_core_v1.ObjectReference{Kind:DockerImage,Namespace:,Name:image-registry.openshift-image-registry.svc:5000/openshift/python@sha256:4ce4f00aeee0b987e768ef3c6f4bc03176e1c0a820469e138036e04778fa6336,UID:,APIVersion:,ResourceVersion:,FieldPath:,},PullSecret:&k8s_io_api_core_v1.LocalObjectReference{Name:builder-dockercfg-vhvwf,},Env:[{PIP_INDEX_URL  nil}],Scripts:,Incremental:nil,ForcePull:false,} nil nil} {&ObjectReference{Kind:ImageStreamTag,Namespace:,Name:django-psql-example:latest,UID:,APIVersion:,ResourceVersion:,FieldPath:,} &LocalObjectReference{Name:builder-dockercfg-vhvwf,} []} {map[] map[]} {[] [] ./manage.py test} <nil> map[]} [{Build configuration change nil nil nil nil nil}]} {Complete false   2020-02-11 20:47:06 +0000 UTC 2020-02-11 20:48:37 +0000 UTC 1m31s image-registry.openshift-image-registry.svc:5000/clusterloader-django-postgresql0/django-psql-example:latest &ObjectReference{Kind:BuildConfig,Namespace:clusterloader-django-postgresql0,Name:django-psql-example,UID:,APIVersion:,ResourceVersion:,FieldPath:,} {&BuildStatusOutputTo{ImageDigest:sha256:24ab915c058b890491e7e2bb96c7836f369e59ea0248deab64db2c2f1b609281,}} [{FetchInputs 2020-02-11 20:47:28 +0000 UTC 629 [{FetchGitSource 2020-02-11 20:47:28 +0000 UTC 629}]} {PullImages 2020-02-11 20:47:36 +0000 UTC 34241 [{PullBaseImage 2020-02-11 20:47:36 +0000 UTC 34241}]} {Build 2020-02-11 20:48:10 +0000 UTC 22636 [{DockerBuild 2020-02-11 20:48:10 +0000 UTC 22636}]} {PushImage 2020-02-11 20:48:33 +0000 UTC 3302 [{PushImage 2020-02-11 20:48:33 +0000 UTC 3302}]}] }}],}
Feb 11 20:51:24.223: INFO: Waiting for build: "django-psql-example-1"
Feb 11 20:51:30.236: INFO: Build "django-psql-example-1" completed
Feb 11 20:51:30.243: INFO: Waiting for deployment: "django-psql-example"
Feb 11 20:51:30.244: INFO: waiting for deploymentconfig clusterloader-django-postgresql0/django-psql-example to be available with version 1

Feb 11 20:51:31.254: INFO: deploymentconfig clusterloader-django-postgresql0/django-psql-example available after 1.009732493s
pods: django-psql-example-1-wttzl

Feb 11 20:51:31.254: INFO: Deployment "django-psql-example" completed
Feb 11 20:51:31.259: INFO: Waiting for 2 RCs in namespace clusterloader-nodejs-mongodb0
Feb 11 20:51:31.259: INFO: Waiting for RC: mongodb-1
Feb 11 20:51:33.267: INFO: Waiting for RC: nodejs-mongodb-example-1
Feb 11 20:51:35.287: INFO: Build List: &BuildList{ListMeta:k8s_io_apimachinery_pkg_apis_meta_v1.ListMeta{SelfLink:/apis/build.openshift.io/v1/namespaces/clusterloader-nodejs-mongodb0/builds,ResourceVersion:117714,Continue:,},Items:[{{ } {nodejs-mongodb-example-1  clusterloader-nodejs-mongodb0 /apis/build.openshift.io/v1/namespaces/clusterloader-nodejs-mongodb0/builds/nodejs-mongodb-example-1 aa563b1c-4d0f-11ea-b906-0a580a81002a 116748 0 2020-02-11 20:47:06 +0000 UTC <nil> <nil> map[app:nodejs-mongodb-example buildconfig:nodejs-mongodb-example openshift.io/build-config.name:nodejs-mongodb-example openshift.io/build.start-policy:Serial template:nodejs-mongodb-example] map[openshift.io/build-config.name:nodejs-mongodb-example openshift.io/build.number:1 openshift.io/build.pod-name:nodejs-mongodb-example-1-build] [{build.openshift.io/v1 BuildConfig nodejs-mongodb-example aa4611f7-4d0f-11ea-94bc-0a580a82001c 0xc00080908b <nil>}] nil []  []} {{builder {Git nil <nil> GitBuildSource{URI:https://github.com/sclorg/nodejs-ex.git,Ref:,ProxyConfig:ProxyConfig{HTTPProxy:nil,HTTPSProxy:nil,NoProxy:nil,},} []  nil [] []} &SourceRevision{Type:Git,Git:&GitSourceRevision{Commit:781a9728b0e4f85c29cb6d4ad342c1a7b783f31a,Author:SourceControlUser{Name:Ben Parees,Email:bparees@users.noreply.github.com,},Committer:SourceControlUser{Name:GitHub,Email:noreply@github.com,},Message:Merge pull request #234 from EmmanuelGit/patch-1,},} {Source nil &SourceBuildStrategy{From:k8s_io_api_core_v1.ObjectReference{Kind:DockerImage,Namespace:,Name:image-registry.openshift-image-registry.svc:5000/openshift/nodejs@sha256:bf4030ac45b8b3ff0ea2892261f1fb5df5b077a67ef717836ac0de879cc775d9,UID:,APIVersion:,ResourceVersion:,FieldPath:,},PullSecret:nil,Env:[{NPM_MIRROR  nil}],Scripts:,Incremental:nil,ForcePull:false,} nil nil} {&ObjectReference{Kind:ImageStreamTag,Namespace:,Name:nodejs-mongodb-example:latest,UID:,APIVersion:,ResourceVersion:,FieldPath:,} &LocalObjectReference{Name:builder-dockercfg-fpb5t,} []} {map[] map[]} {[] [] npm test} <nil> map[]} [{Build configuration change nil nil nil nil nil}]} {Complete false   2020-02-11 20:47:06 +0000 UTC 2020-02-11 20:48:58 +0000 UTC 1m52s image-registry.openshift-image-registry.svc:5000/clusterloader-nodejs-mongodb0/nodejs-mongodb-example:latest &ObjectReference{Kind:BuildConfig,Namespace:clusterloader-nodejs-mongodb0,Name:nodejs-mongodb-example,UID:,APIVersion:,ResourceVersion:,FieldPath:,} {&BuildStatusOutputTo{ImageDigest:sha256:3482fc14e1815a10e47ddadad858f34655b226c25c2922579755abb708a5a432,}} [{FetchInputs 2020-02-11 20:47:23 +0000 UTC 736 [{FetchGitSource 2020-02-11 20:47:23 +0000 UTC 736}]} {PullImages 2020-02-11 20:47:26 +0000 UTC 61111 [{PullBaseImage 2020-02-11 20:47:26 +0000 UTC 61111}]} {Build 2020-02-11 20:48:27 +0000 UTC 28055 [{DockerBuild 2020-02-11 20:48:27 +0000 UTC 28055}]} {PushImage 2020-02-11 20:48:55 +0000 UTC 2454 [{PushImage 2020-02-11 20:48:55 +0000 UTC 2454}]}] }}],}
Feb 11 20:51:35.287: INFO: Waiting for build: "nodejs-mongodb-example-1"
Feb 11 20:51:41.298: INFO: Build "nodejs-mongodb-example-1" completed
Feb 11 20:51:41.305: INFO: Waiting for deployment: "mongodb"
Feb 11 20:51:41.307: INFO: waiting for deploymentconfig clusterloader-nodejs-mongodb0/mongodb to be available with version 1

Feb 11 20:51:42.326: INFO: deploymentconfig clusterloader-nodejs-mongodb0/mongodb available after 1.019506776s
pods: mongodb-1-ckf9f

Feb 11 20:51:42.326: INFO: Deployment "mongodb" completed
Feb 11 20:51:42.331: INFO: Waiting for 2 RCs in namespace clusterloader-rails-postgresql0
Feb 11 20:51:42.331: INFO: Waiting for RC: postgresql-1
Feb 11 20:51:44.340: INFO: Waiting for RC: rails-postgresql-example-1
Feb 11 20:51:46.361: INFO: Build List: &BuildList{ListMeta:k8s_io_apimachinery_pkg_apis_meta_v1.ListMeta{SelfLink:/apis/build.openshift.io/v1/namespaces/clusterloader-rails-postgresql0/builds,ResourceVersion:117769,Continue:,},Items:[{{ } {rails-postgresql-example-1  clusterloader-rails-postgresql0 /apis/build.openshift.io/v1/namespaces/clusterloader-rails-postgresql0/builds/rails-postgresql-example-1 aabc69bf-4d0f-11ea-94bc-0a580a82001c 117397 0 2020-02-11 20:47:07 +0000 UTC <nil> <nil> map[app:rails-postgresql-example buildconfig:rails-postgresql-example openshift.io/build-config.name:rails-postgresql-example openshift.io/build.start-policy:Serial template:rails-postgresql-example] map[openshift.io/build-config.name:rails-postgresql-example openshift.io/build.number:1 openshift.io/build.pod-name:rails-postgresql-example-1-build] [{build.openshift.io/v1 BuildConfig rails-postgresql-example aa93d9c9-4d0f-11ea-b906-0a580a81002a 0xc00372809b <nil>}] nil []  []} {{builder {Git nil <nil> GitBuildSource{URI:https://github.com/sclorg/rails-ex.git,Ref:,ProxyConfig:ProxyConfig{HTTPProxy:nil,HTTPSProxy:nil,NoProxy:nil,},} []  nil [] []} &SourceRevision{Type:Git,Git:&GitSourceRevision{Commit:67d882bbf956145c9e5d5038a73d815a9c098c59,Author:SourceControlUser{Name:Honza Horak,Email:hhorak@redhat.com,},Committer:SourceControlUser{Name:GitHub,Email:noreply@github.com,},Message:Merge pull request #113 from liangxia/okd,},} {Source nil &SourceBuildStrategy{From:k8s_io_api_core_v1.ObjectReference{Kind:DockerImage,Namespace:,Name:image-registry.openshift-image-registry.svc:5000/openshift/ruby@sha256:d773b37c133b1a59dd11e69c801a8021bfcc6c065d1dcb8c19d2a42402596235,UID:,APIVersion:,ResourceVersion:,FieldPath:,},PullSecret:nil,Env:[{RUBYGEM_MIRROR  nil}],Scripts:,Incremental:nil,ForcePull:false,} nil nil} {&ObjectReference{Kind:ImageStreamTag,Namespace:,Name:rails-postgresql-example:latest,UID:,APIVersion:,ResourceVersion:,FieldPath:,} &LocalObjectReference{Name:builder-dockercfg-4k8dv,} []} {map[] map[]} {[] [] bundle exec rake test} <nil> map[]} [{Image change nil nil &ImageChangeCause{ImageID:image-registry.openshift-image-registry.svc:5000/openshift/ruby@sha256:d773b37c133b1a59dd11e69c801a8021bfcc6c065d1dcb8c19d2a42402596235,FromRef:&k8s_io_api_core_v1.ObjectReference{Kind:ImageStreamTag,Namespace:openshift,Name:ruby:2.5,UID:,APIVersion:,ResourceVersion:,FieldPath:,},} nil nil}]} {Complete false   2020-02-11 20:47:07 +0000 UTC 2020-02-11 20:50:46 +0000 UTC 3m39s image-registry.openshift-image-registry.svc:5000/clusterloader-rails-postgresql0/rails-postgresql-example:latest &ObjectReference{Kind:BuildConfig,Namespace:clusterloader-rails-postgresql0,Name:rails-postgresql-example,UID:,APIVersion:,ResourceVersion:,FieldPath:,} {&BuildStatusOutputTo{ImageDigest:sha256:eb151e9216e99ac10854a976b359a2cdba5ecbee53fede1246100e099850c0eb,}} [{FetchInputs 2020-02-11 20:47:24 +0000 UTC 632 [{FetchGitSource 2020-02-11 20:47:24 +0000 UTC 632}]} {PullImages 2020-02-11 20:47:27 +0000 UTC 57936 [{PullBaseImage 2020-02-11 20:47:27 +0000 UTC 57936}]} {Build 2020-02-11 20:48:25 +0000 UTC 135126 [{DockerBuild 2020-02-11 20:48:25 +0000 UTC 135126}]} {PushImage 2020-02-11 20:50:40 +0000 UTC 5152 [{PushImage 2020-02-11 20:50:40 +0000 UTC 5152}]}] }}],}
Feb 11 20:51:46.361: INFO: Waiting for build: "rails-postgresql-example-1"
Feb 11 20:51:52.374: INFO: Build "rails-postgresql-example-1" completed
Feb 11 20:51:52.381: INFO: Waiting for deployment: "postgresql"
Feb 11 20:51:52.383: INFO: waiting for deploymentconfig clusterloader-rails-postgresql0/postgresql to be available with version 1

Feb 11 20:51:53.393: INFO: deploymentconfig clusterloader-rails-postgresql0/postgresql available after 1.010282484s
pods: postgresql-1-fcvnv

Feb 11 20:51:53.393: INFO: Deployment "postgresql" completed
{"marker":"cluster_loader_marker","name":"cluster-loader-test","type":"metrics.TestDuration","startTime":"2020-02-11T20:47:04.631153504Z","testDuration":288762170296,"Steps":[{"type":"metrics.TemplateStepDuration","startTime":"2020-02-11T20:47:04.759139161Z","totalTime":328259785,"rateDelay":0,"rateDelayCount":0,"stepPause":0,"stepPauseCount":0,"syncTime":479},{"type":"metrics.TemplateStepDuration","startTime":"2020-02-11T20:47:05.209864859Z","totalTime":333494288,"rateDelay":0,"rateDelayCount":0,"stepPause":0,"stepPauseCount":0,"syncTime":172},{"type":"metrics.TemplateStepDuration","startTime":"2020-02-11T20:47:05.685183134Z","totalTime":385522829,"rateDelay":0,"rateDelayCount":0,"stepPause":0,"stepPauseCount":0,"syncTime":185},{"type":"metrics.TemplateStepDuration","startTime":"2020-02-11T20:47:06.205346661Z","totalTime":326000112,"rateDelay":0,"rateDelayCount":0,"stepPause":0,"stepPauseCount":0,"syncTime":200},{"type":"metrics.TemplateStepDuration","startTime":"2020-02-11T20:47:06.68367389Z","totalTime":370627847,"rateDelay":0,"rateDelayCount":0,"stepPause":0,"stepPauseCount":0,"syncTime":160}]}
Feb 11 20:51:53.393: INFO: Deleting project clusterloader-cakephp-mysql0
Feb 11 20:51:53.403: INFO: Deleting project clusterloader-dancer-mysql0
Feb 11 20:51:53.414: INFO: Deleting project clusterloader-django-postgresql0
Feb 11 20:51:53.424: INFO: Deleting project clusterloader-nodejs-mongodb0
Feb 11 20:51:53.435: INFO: Deleting project clusterloader-rails-postgresql0
[AfterEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/client.go:120
[AfterEach] [Feature:Performance][Serial][Slow] Load cluster
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:150
Feb 11 20:51:53.446: INFO: Waiting up to 3m0s for all (but 100) nodes to be ready
Feb 11 20:51:53.454: INFO: Running AfterSuite actions on all nodes
Feb 11 20:51:53.454: INFO: Running AfterSuite actions on node 1

Comment 5 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460


Note You need to log in before you can comment on or make changes to this bug.