Bug 1765308 - Can not create cluster in AWS region Stockholm (eu-north-1) via IPI
Summary: Can not create cluster in AWS region Stockholm (eu-north-1) via IPI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Scott Dodson
QA Contact: sheng.lao
URL:
Whiteboard:
Depends On: 1765269
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-24 19:16 UTC by Scott Dodson
Modified: 2019-11-13 18:56 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1765269
Environment:
Last Closed: 2019-11-13 18:56:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2568 0 'None' closed Bug 1765308: pkg/types/aws/validation/platform: Include eu-north-1 2020-08-06 23:52:32 UTC
Red Hat Product Errata RHBA-2019:3303 0 None None None 2019-11-13 18:56:13 UTC

Description Scott Dodson 2019-10-24 19:16:25 UTC
+++ This bug was initially created as a clone of Bug #1765269 +++

User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36
Build Identifier: 

The ocp 4.2 installer does not list eu-north-1 (Stockholm) in the list of AWS regions.

Only options are eu-central (Frankfort), eu-west-1 (Ireland), eu-west-2 (London) and eu-west-3 (Paris)



Reproducible: Always

Steps to Reproduce:
1. Run openshift-installer create install-config
2. Select 'aws' platform
3. notice the select list of AWS regions does not include eu-north-1 (Stockholm)
Actual Results:  
Can't select desired AWS region

Expected Results:  
Deploy OCP 4.2 cluster in eu-north-1 (Stockholm) AWS region

I'm working with a customer who has an OCP 3.11 cluster running in eu-north-1 and wants to run OCP 4.2 in the same region.

--- Additional comment from Abhinav Dahiya on 2019-10-24 13:55:25 EDT ---

There is no AMI available for RHCOS in that regions.

--- Additional comment from Colin Walters on 2019-10-24 14:07:03 EDT ---

https://github.com/openshift/installer/blob/e349157f325dba2d06666987603da39965be5319/data/data/rhcos.json#L24 right?

But there's installer steps needed too which happened in https://github.com/openshift/installer/pull/2308 and just needs backporting to 4.2 I believe.

Comment 1 Kathryn Alexander 2019-10-24 20:58:38 UTC
@Jianlin, this region was added to 4.2: https://github.com/openshift/installer/pull/2308/files

Will you please confirm that this region works and approve docs change here? https://github.com/openshift/openshift-docs/pull/17602

Comment 2 W. Trevor King 2019-10-24 22:11:18 UTC
4.2.z PR is still in flight.

Comment 3 W. Trevor King 2019-10-24 22:12:30 UTC
But that PR is blocking on getting the 4.3.0 bug 1765269 VERIFIED.

Comment 5 sheng.lao 2019-10-28 06:55:54 UTC
Verified it with 4.2.0-0.nightly-2019-10-27-140004

# openshift-install create cluster --dir bz-1765308
...
? Region eu-north-1
? Base Domain  [Use arrows to move, type to filter, ? for more help]

# export KUBECONFIG=`pwd`/kubeconfig
# sh check_cluster_health.sh
Passed

Comment 7 errata-xmlrpc 2019-11-13 18:56:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3303


Note You need to log in before you can comment on or make changes to this bug.