Bug 176537 - Kickstart | RAID options
Summary: Kickstart | RAID options
Alias: None
Product: Fedora
Classification: Fedora
Component: pykickstart
Version: rawhide
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2005-12-25 01:11 UTC by W Agtail
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Clone Of:
Last Closed: 2006-07-05 19:27:18 UTC

Attachments (Terms of Use)
kickstart file - ks.cfg (3.80 KB, text/plain)
2006-01-05 23:28 UTC, W Agtail
no flags Details
anacdump.txt (81.27 KB, text/plain)
2006-06-16 20:40 UTC, W Agtail
no flags Details
anaconda.log (13.31 KB, text/plain)
2006-06-16 20:41 UTC, W Agtail
no flags Details

Description W Agtail 2005-12-25 01:11:49 UTC
Description of problem:
Unable to configure LVM on RAID in ks.cfg file.

Version-Release number of selected component (if applicable):
FC5 test 1

How reproducible:

Steps to Reproduce:
ks.cfg section:
part raid.11 --onpart=hda1
part raid.12 --onpart=hdc1
raid swap --fstype=swap --level=1 --device md1 raid.11 raid.12

I have tried the following raid options:
#raid swap --fstype=swap --level=RAID1 --device md1 raid.11 raid.12
#raid swap --fstype=swap --level=RAID1 --device=md1 raid.11 raid.12
#raid swap --fstype=swap --level=1     --device=md1 raid.11 raid.12
#raid swap --fstype swap --level=RAID1 --device md1 raid.11 raid.12

This did work for FC4:
part raid.11 --onpart=hda1
part raid.12 --onpart=hdc1
raid swap --fstype=swap --level=1 --device=md1 raid.11 raid.12
Actual results:
I use 'text' mode in ks.cfg to install. Anaconda errors after mouse & screen
have been probed. Error messages go scrolling off the screen too quick to catch
'em all. But do see something refering to: DoRaid. My ks.cfg file works fine
without RAID.

Expected results:
LVM on RAID installation.

Additional info:
I've also refered to:

I also tried: system-config-kickstart on FC5 test1
and got error:
# I/O warning : failed to load external entity "/usr/share/comps/i386/comps.xml"
Could not start because there is no /usr/share/comps/i386/comps.xml file.
Please make sure the comps package is installed.

I could not find comps RPM. So copied file from FC5 CD1 and then got error message:

# Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 82,
in ?
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 165, in __init__
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 311, in fillData
  File "/usr/share/system-config-kickstart/xconfig.py", line 274, in fillData
    if self.ksdata.xconfig["monitor"] != "":
KeyError: 'monitor'

Comment 1 Chris Lumens 2006-01-04 20:07:52 UTC
You can find the errors anaconda spits out in /tmp/anaconda.log and sometimes
also /tmp/anacdump if you get a traceback.  Please attach those to this bug
report and I'll be able to fix the problem.

Comment 2 W Agtail 2006-01-05 21:20:59 UTC

Thanks for coming back to me. I don't think the installer gets far enough to
allow me to get to a shell prompt. A shell appears on [alt]+[f2], but i'm unable
to type any commands :( 

Another reason is that, the installer 'exited abnormally' and unmounted all
files systems.

Thus unable to see any files in /tmp. Is there another way of getting at these

Are you able to create RAID and LVM on RAID in kickstart?

Regards W Agtail

Comment 3 Chris Lumens 2006-01-05 22:03:36 UTC
After the exception dialog pops up and prompts you to save it to a floppy or
remote machine, just don't hit any of the buttons or press enter.  As long as
the exception dialog is up, you should be able to switch over to tty2 and get to
the log files from there.

I have not tested LVM on RAID recently, though I know that RAID through
kickstart should be working.

Comment 4 Chris Lumens 2006-01-05 22:08:34 UTC
Also, could you attach your whole kickstart config file (minus any passwords, etc.)?

Comment 5 W Agtail 2006-01-05 23:28:32 UTC
Created attachment 122854 [details]
kickstart file - ks.cfg

My ks.cfg file - refer to 'LVM on RAID' section - thanks

Comment 6 W Agtail 2006-01-05 23:33:02 UTC
Hi, as requested, please find attached my ks.cfg file.

I didn't get any exception dialog prompts :(

Many thanks, W Agtail

Comment 7 Chris Lumens 2006-01-09 19:57:32 UTC
The biggest problem I see is that you don't have any root partition defined. 
You have a couple lines in there, but they are commented out.  That'd certainly
cause anaconda to halt.  I can't reproduce your problem on rawhide, even with
LVM on RAID setups.

Comment 8 Ryan O'Hara 2006-02-25 19:45:33 UTC
I can confirm that this is still a problem in FC5 test 3. I have a similar
ks.cfg and hit this problem. I looked through the code and it appears that
anaconda does not accept "swap" after the "raid" command.

Sorry I can't get a traceback -- the installed locks up after I get the error.
In brief, what I am seeing is that kickstart.py line 459 (doRaid) doesn't handle
"swap" as the mountpoint. It expects the first character to be a "/" or the
string to be empty.

On a sidenote, I tried to work around this problem by making my swap partitions
non-raid (just create swap with "part"). This caused other more confusing
problems for the raid config. I'll try to recreate that problem and post a
seperate bz with tracebacks.

Comment 9 Ryan O'Hara 2006-02-26 19:40:13 UTC
It definitely seems that having a line in ks.cfg such as ...

raid swap --fstype=swap --level=1 --device=md1 raid.11 raid.12

will not work for the reasons mentioned above. Note that this did work for FC4,
and in my humble opinion it should still be valid.

I attempted to move the swap to a regular "part" command in ks.cfg. For example:

part swap --fstype=swap --onpart=sda
part swap --fstype=swap --onpart=sdb

At the same time all of my regular partitions (with ext3 as fstype) were
configured as raid. Each specified the md device (--device=md#). This caused
some strange behavior, namely that the installed would fail to format md1. I can
recreate this. Once this happened I would go to the shell and get some info
using mdadm. It appeared that md1 was not being used. For example:

raid /boot --fstype=ext3 --level=1 --device=md0 raid.10 raid.11
raid /     --fstype=ext3 --level=0 --device=md1 raid.12 raid.13
raid /usr  --fstype=ext3 --level=0 --device=md2 raid.14 raid.15
raid /var  --fstype=ext3 --level=0 --device=md3 raid.16 raid.17
raid /tmp  --fstype=ext3 --level=0 --device=md4 raid.18 raid.19
raid /home --fstype=ext3 --level=0 --device=md5 raid.20 raid.21

The above raid config would not work, failing each time while trying to format
md1. Note that my swap partitions were configured with "part" as stated above.

My work-around was to not use md1, ie. replace md1 (above) with md2 and bump all
the md# by one. I'm not sure what md1 is causing problems. It should be valid.

I think the best solution is to allow swap to be a "mount point" for the raid
command, as in FC4.

Comment 10 Chris Lumens 2006-02-27 15:25:28 UTC
Committed a fix to Rawhide.  Please test with the next anaconda build.

Comment 11 W Agtail 2006-03-16 12:47:25 UTC
I'm testing again with FC5-test3-x86_64 and still see the same problems.
I'm not sure how to access Rawhide?

Comment 12 Chris Lumens 2006-03-29 15:21:04 UTC
Is this better in FC5 final?

Comment 13 John Thacker 2006-05-05 21:11:04 UTC
Closing due to no response by reporter.
If this still happens in FC5 final, please reopen.

Comment 14 W Agtail 2006-06-16 20:39:17 UTC
Hi, I've been away for while and just trying this with final release of FC5.

I'm still seeing problems. section of ks.cfg file looks like this:
bootloader --location=partition --driveorder=sda,sdb --append="rhgb quiet"


# swap mirrored
part raid.11 --onpart=sda1
part raid.12 --onpart=sdb1
raid swap --fstype=swap --level=1 --device=md1 raid.11 raid.12

# /boot mirrored
part raid.21 --onpart=sda2
part raid.22 --onpart=sdb2
raid /boot --fstype=ext3 --level=1 --device=md2 raid.21 raid.22

# /root mirrored
part raid.31 --onpart=sda3
part raid.32 --onpart=sdb3
raid / --fstype=ext3 --level=1 --device=md3 raid.31 raid.32

part raid.51 --ondisk=sda --size=1 --grow
part raid.52 --ondisk=sdb --size=1 --grow
raid pv.5 --fstype "physical volume (LVM)" --level=1 --device=md5 raid.51 raid.52

volgroup sys --pesize=32768 pv.5
logvol /usr       --vgname=sys --size=10240 --name=usr       --fstype=ext3
logvol /usr/local --vgname=sys --size=1024  --name=usrlocal  --fstype=reiserfs
logvol /opt       --vgname=sys --size=1024  --name=opt       --fstype=reiserfs
logvol /tmp       --vgname=sys --size=1024  --name=tmp       --fstype=reiserfs
logvol /var       --vgname=sys --size=5120  --name=var       --fstype=ext3
logvol /var/www   --vgname=sys --size=2048  --name=varwww    --fstype=ext3
logvol /home      --vgname=sys --size=8192  --name=home      --fstype=ext3
logvol /audio     --vgname=sys --size=14336 --name=audio     --fstype=reiserfs
logvol /downloads --vgname=sys --size=4096  --name=downloads --fstype=ext3
logvol /scratch   --vgname=sys --size=1     --name=scratch   --fstype=reiserfs

# Refer to: egrep "<id>|<name>|<description>|<packagereq|<subcategory>"
# Minimum Install
@ admin-tools
@ base
@ base-x
@ core
@ development-tools
@ dialup
@ editors
@ gnome-desktop
@ graphical-internet
@ sound-and-video

# Install almost everything.
#@ Everything

# Trash partition table on sda (primary) and sdb (mirror).
# Add partitions ready for swap(2G), /boot(128M) and /(1G).
parted -s /dev/sda mklabel msdos
parted -s /dev/sda mkpart primary 0    2048
parted -s /dev/sda mkpart primary 2048 2176
parted -s /dev/sda mkpart primary 2176 3200
parted -s /dev/sdb mklabel msdos
parted -s /dev/sdb mkpart primary 0    2048
parted -s /dev/sdb mkpart primary 2048 2176
parted -s /dev/sdb mkpart primary 2176 3200

echo "# Version 1.1

Comment 15 W Agtail 2006-06-16 20:40:49 UTC
Created attachment 131083 [details]

Comment 16 W Agtail 2006-06-16 20:41:34 UTC
Created attachment 131084 [details]

Comment 17 W Agtail 2006-06-17 14:07:43 UTC
Just to confirm, this ks file works ok with FC4.

Comment 18 W Agtail 2006-06-18 16:06:51 UTC
FYI: I just tried today's rawhide version from:
and get the same results :(

thanks, Wagtail

Comment 19 Chris Lumens 2006-06-20 18:26:16 UTC
This should be fixed in Rawhide after FC6 test1.

Comment 20 W Agtail 2006-07-03 19:26:02 UTC
I've tried several revisions of rawhide. For example today's rawhide breaks at
kickstart. The process seems to 'blue screen'.

doesn't get as far as a shell session.

i'm installing using PXE and another another FC computer for DHCP etc.

Comment 21 Chris Lumens 2006-07-05 19:27:18 UTC
If you are seeing problems with anaconda besides this bug, please open different
bugs against anaconda.  Otherwise, please only reopen this bug if you are
continuing to see this same problem.

Note You need to log in before you can comment on or make changes to this bug.