Bug 1765438 - rhel-registration by default includes rhel7 base repository
Summary: rhel-registration by default includes rhel7 base repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alex Schultz
QA Contact: Jad Haj Yahya
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-25 06:05 UTC by Jaison Raju
Modified: 2020-03-05 12:00 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.2-0.20191202200455.41d9f8a.el8ost
Doc Type: Removed functionality
Doc Text:
In Red Hat OpenStack Platform (RHOSP) 15, the rhel-registration pre-deployment script has been removed because it is not compatible with RHEL8. Use the Ansible-based overcloud registration method instead: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15/html/advanced_overcloud_customization/ansible-based-registration
Clone Of:
Environment:
Last Closed: 2020-03-05 12:00:15 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0643 0 None None None 2020-03-05 12:00:57 UTC

Description Jaison Raju 2019-10-25 06:05:12 UTC
Description of problem:
Since RHOS15 is based on RHEL8, the THT should not attempt by default to enable rhel7 repository.
Although the following file does add rhel-7-server-rpms repo as default.

$ grep -n ^repos /usr/share/openstack-tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/scripts/rhel-registration-bak
19:repos="repos --enable rhel-7-server-rpms"


Version-Release number of selected component (if applicable):
RHOS15z1
This is not fixed in upstream too

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Alex Schultz 2019-10-25 15:13:27 UTC
rhel-registration script should not be used. We replaced it with an ansible role back in OSP14.


https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15/html/advanced_overcloud_customization/ansible-based-registration

Comment 5 Alex Schultz 2019-10-25 18:07:19 UTC
The bug here is likely that we should actually remove the old script for OSP15 because it does not work. I believe we have removed it upstream but I think it landed in train.

Comment 8 errata-xmlrpc 2020-03-05 12:00:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0643


Note You need to log in before you can comment on or make changes to this bug.