Bug 176546 - init scripts and default clamd/freshclam conf is missing
Summary: init scripts and default clamd/freshclam conf is missing
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Enrico Scholz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-25 13:36 UTC by Thomas M Steenholdt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-25 14:35:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas M Steenholdt 2005-12-25 13:36:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
In order for the default installation of clamav parts to be in same kind of shape as other fedora packages after install, a default configuration file for clamd should be provided (possible implementing the example option, to ensure admins will revisit the file before relying on it).
There should be an initscript that takes care of handling start/stop and status of the clamd daemon as well as an init script to enable periodic (cron based?) freshclam updates (tihnk something like the yum initscript).
The upstream mentioned ports for fedora distributions has put al this in place and its a shame that for fedora, clamav.net does not just point to fedora extras. Changes like these could probably help us in that direction.

Version-Release number of selected component (if applicable):
0.87.1-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. install clamav packages and look at /etc/clamd.conf /etc/init.d/{fres,clam}*
2. Erhm, file not found?

  

Actual Results:  no default config file or initscripts are found.

Additional info:

we should have a sane default config, possibly with the Example option enabled and initscripts for clamd and freshclam.

Comment 1 Enrico Scholz 2005-12-25 14:35:57 UTC
not a bug. freshclam is executed by cron, and a system-wide clamav daemon can
not exist. For details see /usr/share/doc/clamav-server-0.87.1/README

Comment 2 Thomas M Steenholdt 2005-12-25 21:56:54 UTC
I'm not sure I get it. I understand that there are good reasons for having a
clamd instance for each group of users and such, but how about a generic service
that alows for nothing more than db updates and stuff like STREAM scanning. As I
understand it, freshclam needs clamd to run??! I may be wrong here.

Also, if the is the "right"(tm) solution, howcome upstream is pointing to
packages that offer all the things that I am asking for here, and not directly
to fedora-extras? I'm not trying to tell you guys that you are wrong, but it
seems wrong to me and I wish to understand. If there's some mailing list or
something where I can learn the reasons for this, please let me know?

Thanks


Note You need to log in before you can comment on or make changes to this bug.