Bug 1765518 - [IPI][OSP] DNS servers on tenant network
Summary: [IPI][OSP] DNS servers on tenant network
Keywords:
Status: CLOSED DUPLICATE of bug 1734539
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: egarcia
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-25 10:29 UTC by Luis Arizmendi
Modified: 2019-11-13 18:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-13 18:25:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2132 'None' closed Bug 1734539: Openstack: Option to set multiple external DNS IP Addresses 2020-02-24 11:02:03 UTC

Description Luis Arizmendi 2019-10-25 10:29:29 UTC
Description of problem:

You cannot configure dns servers for the autocreated tenant network so in case that you don't have NeutronEnableInternalDNS: true or DNS servers configured under the param NeutronDhcpAgentDnsmasqDnsServers in your overcloud configuration, the VMs (first the bootstrap) won't get a valid DNS server that can resolve, for example quay.io unless you configure manually the dns servers on that neutron subnet.

Since this depends on the underlying OpenStack we would need to either bring that configuration option or just explain this in the DOCs



Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:
always

Steps to Reproduce:
1.Install OCP 4.2 using IPI OSP without dns servers added to the subnet 

Actual results:
bootstrap cannot access quay.io since it cannot resolve the name

Expected results:
You have a valid dns server configured in the VMs 

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Tomas Sedovic 2019-10-25 15:04:53 UTC
This pull request adds the `externalDNS` option for exactly this situation: https://github.com/openshift/installer/pull/2132

I'm moving this BZ to Emilio Garcia who is the author of that pull request.

Comment 3 Eric Duen 2019-11-13 18:25:55 UTC

*** This bug has been marked as a duplicate of bug 1734539 ***


Note You need to log in before you can comment on or make changes to this bug.