Bug 1765546 - RFE: add Zyn-Fusion UI to ZynAddSubFX
Summary: RFE: add Zyn-Fusion UI to ZynAddSubFX
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: zynaddsubfx
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guido Aulisi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-25 11:46 UTC by Patrick Laimbock
Modified: 2020-10-26 12:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-26 12:07:15 UTC
Type: Bug


Attachments (Terms of Use)
ZynAddSubFX spec file with Zyn-Fusion enabled (16.55 KB, text/x-rpm-spec)
2019-10-25 11:46 UTC, Patrick Laimbock
no flags Details

Description Patrick Laimbock 2019-10-25 11:46:13 UTC
Created attachment 1629143 [details]
ZynAddSubFX spec file with Zyn-Fusion enabled

Description of problem:
ZynAddSubFX release 3.0.5 comes with a new UI called Zyn-Fusion which is currently not included.

Version-Release number of selected component (if applicable):
3.0.5

How reproducible:
Start ZynAddSubFX and note the non-Zyn-Fusion UI

Steps to Reproduce:
1. Start ZynAddSubFX
2. Look at screen
3. no Zyn-Fusion UI

Actual results:
Zyn-Fusion UI not available,

Expected results:
Would appreciate the Zyn-Fusion UI.

Additional info:
I have a attached a spec file which includes the Zyn-Fusion UI. Tested the LV2 plugin with Ardour5 on F31 and it worked. Please let me know if you have any questions. Thanks for packaging ZynAddSubFX!

Comment 1 Guido Aulisi 2020-04-19 14:22:59 UTC
Zyn-Fusion UI contains too many bundled libraries and it would be a very hard work to unbundle all of them, see [0].

[0]: https://docs.fedoraproject.org/en-US/packaging-guidelines/#bundling

Comment 2 drollma 2020-10-25 16:46:15 UTC
The old zynaddsubfx ui is pretty terrible and unusable.

The link you sent @guido.aulisi states:



>All packages whose upstreams allow them to be built against system libraries MUST be built against system libraries.

>All packages whose upstreams have no mechanism to build against system libraries MAY opt to carry bundled libraries, but if they do, they MUST include an indication of what they bundle.

It seems it's fine to include bundled libraries in this case.

Which libraries specifically are you thinking of?

Comment 3 Patrick Laimbock 2020-10-25 17:39:59 UTC
Not a developer so I don't know which are libs or not but the zyn-ui-src 3.0.5 comes with these dirs

in deps/

mruby-complex
mruby-dir-glob
mruby-glew
mruby-glfw3
mruby-io
mruby-nanovg
mruby-regexp-pcre
mruby-set
mruby-sleep
nanovg
pugl
rtosc

in src/

mruby-qml-parse
mruby-qml-spawn
mruby-widget-lib
mruby-zest
osc-bridge

And the Makefile pulls in libuv-1.9.1

Comment 4 Guido Aulisi 2020-10-26 07:54:48 UTC
pugl should be unbundled, because many other packages use it.

Anyway I think the right way should be to unbundle all the libraries, consider also that prebuilt software is forbidden in Fedora.
Any help would be kindly appreciated...

And I don't think UI is the most important part of audio software, I really prefer great sounding than good appearance.

Comment 5 Patrick Laimbock 2020-10-26 12:07:15 UTC
Not a developer so can't unbundle. Will close this BZ. Thank you for your time.


Note You need to log in before you can comment on or make changes to this bug.