Bug 1765573 - Please package wxpython4 also for EPEL-8
Summary: Please package wxpython4 also for EPEL-8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-wxpython4
Version: epel8
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1774207
Blocks: 1856949
TreeView+ depends on / blocked
 
Reported: 2019-10-25 13:00 UTC by markusN
Modified: 2020-11-29 01:18 UTC (History)
8 users (show)

Fixed In Version: python-wxpython4-4.0.7-13.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-29 01:18:46 UTC
Type: Bug


Attachments (Terms of Use)
sip.spec (33.27 KB, text/x-matlab)
2020-05-31 16:39 UTC, markusN
no flags Details

Description markusN 2019-10-25 13:00:41 UTC
Please package wxpython4 also for Centos/EPEL.

The GRASS GIS package is ready also for EPEL7 and 8, using Python 3 but there is no EPEL package yet:

https://koji.fedoraproject.org/koji/packageinfo?packageID=26351

Maybe other packages would also benefit from it.

Comment 1 markusN 2019-11-23 08:16:29 UTC
If possible, pls then trigger a rebuild of GRASS GIS 7.8.x for EPEL:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-425c9076d3

Comment 2 Scott Talbert 2019-11-23 16:53:27 UTC
(In reply to markusN from comment #1)
> If possible, pls then trigger a rebuild of GRASS GIS 7.8.x for EPEL:
> 
> https://bodhi.fedoraproject.org/updates/FEDORA-2019-425c9076d3

I am not sure I understand the request.  This bug is for wxpython4 in EPEL8 which is not ready yet.  That Bodhi update is for F31.  However, even when wxpython4 is ready, I don't see why GRASS would need to be rebuilt, and I don't have permissions to do that anyway.

Comment 3 markusN 2019-11-25 16:35:03 UTC
ok, sorry for the confusion. I thought that once the package is ready other packages depending on it could be triggered for rebuild. I'll try to figure it out once wxpython4 is available.
Thanks again for your efforts to bring wxpython4 into EPEL.

Comment 4 Scott Talbert 2019-11-25 16:37:25 UTC
(In reply to markusN from comment #3)
> ok, sorry for the confusion. I thought that once the package is ready other
> packages depending on it could be triggered for rebuild. I'll try to figure
> it out once wxpython4 is available.
> Thanks again for your efforts to bring wxpython4 into EPEL.

Why would anything need to be rebuilt once wxpython is added, though?

Comment 5 markusN 2019-11-26 13:21:35 UTC
I tried to address this problem:
https://lists.osgeo.org/pipermail/grass-user/2019-October/080940.html
"ERROR: wxGUI requires wxPython. No module named 'wx'"

hence:
https://lists.osgeo.org/pipermail/grass-user/2019-October/080945.html

and believe that I have to recompile the GRASS GIS package for EPEL (yet on COPR, I hope to see it here as well in future).

Comment 6 markusN 2020-05-09 12:32:47 UTC
I tried to rebuild python-wxpython4-4.0.7-4.el7.src.rpm on Centos 8 but I didn't succeed due to missing SIP.

This is the missing piece to also make the GUI of GRASS GIS available on Centos 8
(https://koji.fedoraproject.org/koji/buildinfo?buildID=1504605 now compiles fine also on Centos 7).

Any pointers what to do for Centos 8? Thanks.

Comment 7 Scott Talbert 2020-05-09 15:12:56 UTC
(In reply to markusN from comment #6)
> I tried to rebuild python-wxpython4-4.0.7-4.el7.src.rpm on Centos 8 but I
> didn't succeed due to missing SIP.
> 
> This is the missing piece to also make the GUI of GRASS GIS available on
> Centos 8
> (https://koji.fedoraproject.org/koji/buildinfo?buildID=1504605 now compiles
> fine also on Centos 7).
> 
> Any pointers what to do for Centos 8? Thanks.

Yes, that is the problem.  We're still blocked waiting on sip, which is part of RHEL.  See the linked bug report.  Unfortunately, I'm stuck waiting on action from Red Hat.

Comment 8 markusN 2020-05-13 08:51:58 UTC
I see - anything I can do here?

Comment 9 Scott Talbert 2020-05-13 18:01:45 UTC
(In reply to markusN from comment #8)
> I see - anything I can do here?

I'm afraid not, unless you know someone in Red Hat.

Comment 10 markusN 2020-05-31 16:39:09 UTC
Created attachment 1693899 [details]
sip.spec

sip.spec updated to EPEL8

Comment 11 markusN 2020-05-31 16:41:12 UTC
Attached sip.spec now compiles also on EPEL8 (here: Centos 8).

With that I was able to compile python-wxpython4.spec.

Only dirty local hack was
sudo ln -s /usr/include/python3.6/sip.h /usr/include/sip.h

which needs to be addressed somewhere in the SPEC file.

After installation of the binary RPMs, I can successfully run the GUI of GRASS GIS also on Centos 8.

Comment 12 Scott Talbert 2020-07-14 23:26:57 UTC
The updated SIP that I need has shown up in CentOS Stream, but I think it probably won't be in CentOS proper until 8.3 comes out.

Comment 13 Fedora Update System 2020-11-13 03:17:22 UTC
FEDORA-EPEL-2020-1a5c5f1eb1 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-1a5c5f1eb1

Comment 14 Fedora Update System 2020-11-14 02:12:28 UTC
FEDORA-EPEL-2020-1a5c5f1eb1 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-1a5c5f1eb1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-11-29 01:18:46 UTC
FEDORA-EPEL-2020-1a5c5f1eb1 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.