Bug 176563 - stack smashing detected in ifconfig
Summary: stack smashing detected in ifconfig
Status: CLOSED DUPLICATE of bug 176714
Alias: None
Product: Fedora
Classification: Fedora
Component: net-tools   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-26 14:34 UTC by Anton Guda
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 10:06:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anton Guda 2005-12-26 14:34:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; ru) KHTML/3.5.0 (like Gecko)

Description of problem:
After a approx 1 week of work one of my servers  
fail to run ifconfig or ifconfig -a. 
 
Output is 'stack smashing detected'.  
Other my hosts works without problem.  
 
ifconfig eth0 ... eth4 works 
ifconfig eth4.1  eth4.100 ... failed  

Version-Release number of selected component (if applicable):
net-tools-1.60-57

How reproducible:
Sometimes

Steps to Reproduce:
1. Wait approx 1 week after reboot at one of may hosts (sorry). 
2. Run ifconfig or ifconfig -a 
 
   

Actual Results:  Stack smashing detected, not other output. 

Expected Results:  Output if interfaces status. 

Additional info:

This host have 14 interfaces, some of them VLAN. 
 
stack trace from ifconfig: 
 
#0  0x00d63235 in raise () from /lib/libc.so.6 
#1  0x00d647ce in abort () from /lib/libc.so.6 
#2  0x00d97826 in __fsetlocking () from /lib/libc.so.6 
#3  0x00e18799 in __stack_chk_fail () from /lib/libc.so.6 
#4  0x0804f855 in if_readlist_proc (target=Variable "target" is not available. 
) at interface.c:373 
#5  0x0804f86d in if_readlist () at interface.c:415 
#6  0x0804fa6a in for_all_interfaces (doit=0x8051960 <do_if_print>, 
    cookie=0x8057c8c) at interface.c:134 
#7  0x08049415 in if_print (ifname=0x0) at ifconfig.c:113 
#8  0x0804a7a5 in main (argc=0, argv=0xbfa23534) at ifconfig.c:357

Comment 1 Radek Vokal 2006-01-02 10:06:00 UTC

*** This bug has been marked as a duplicate of 176714 ***


Note You need to log in before you can comment on or make changes to this bug.