Bug 176568 - The path /media/cdrecorder does not look like a valid installation source
The path /media/cdrecorder does not look like a valid installation source
Status: CLOSED DUPLICATE of bug 188750
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-26 12:15 EST by Kevin Verma
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 21:23:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Verma 2005-12-26 12:15:21 EST
Description of problem:
The package in question does not work at all. I have tried using this program
with CD1 both mounted/un-mounted on /media/crecorder and /media/cdrom also on a
valid instalation tree under a directory as /var/ftp/pub/FC5 the dir listing as
below:
[root@server1 packages]# ls /var/ftp/pub/FC5/
autorun   GPL       lost+found            RELEASE-NOTES  RPM-GPG-KEY-beta      
     RPM-GPG-KEY-fedora-test
eula.txt  images    README                repodata       RPM-GPG-KEY-fedora    
     RPM-GPG-KEY-rawhide
Fedora    isolinux  README-Accessibility  RPM-GPG-KEY   
RPM-GPG-KEY-fedora-rawhide  TRANS.TBL


Version-Release number of selected component (if applicable):
system-config-packages-1.2.25-1.1

How reproducible:
Reproducible on every single attempt

Steps to Reproduce:
1. /usr/sbin/system-config-packages
"The path /media/cdrecorder does not look like a valid installation source"

2. /usr/sbin/system-config-packages --tree=/var/ftp/pub/FC5/
""

3. umount /media/cdrecorder/
/usr/sbin/system-config-packages
"The path /media/cdrecorder does not look like a valid installation source"

4. mount /dev/hdd /media/cdrom/
/usr/sbin/system-config-packages
"The path /media/cdrecorder does not look like a valid installation source"
  
Actual results:
While trying --tree option out put on terminal was:
/usr/share/system-config-packages/package_gui.py:312: DeprecationWarning: Class
PackageSelectionWindow is already GObject-registered; Please note that classes
containing any of the attributes __gtype_name__, __gproperties__, or
__gsignals__ are now automatically registered.
  gobject.type_register(PackageSelectionWindow)

While trying without any option output was:
/usr/share/system-config-packages/package_gui.py:312: DeprecationWarning: Class
PackageSelectionWindow is already GObject-registered; Please note that classes
containing any of the attributes __gtype_name__, __gproperties__, or
__gsignals__ are now automatically registered.
  gobject.type_register(PackageSelectionWindow)
hal devs is {'/dev/hdd': '/media/cdrom'}

Noticeble "hal devs is {'/dev/hdd': '/media/cdrom'}" is from above !

Expected results:


Additional info:
Perhaps the hal maintainers need to be marked a CC as well, you decide
Comment 1 Kevin Verma 2005-12-26 12:23:04 EST
Below is output from the --tree option as I forgot to paste above;

[root@server1 packages]# /usr/sbin/system-config-packages --tree=/var/ftp/pub/FC5/
/usr/share/system-config-packages/package_gui.py:312: DeprecationWarning: Class
PackageSelectionWindow is already GObject-registered; Please note that classes
containing any of the attributes __gtype_name__, __gproperties__, or
__gsignals__ are now automatically registered.
  gobject.type_register(PackageSelectionWindow)
Comment 2 John Thacker 2006-04-21 21:23:54 EDT
system-config-packages replaced by pirut.  

This has a corresponding pirut bug about installing from a CD later.  Setting as
duplicate.

*** This bug has been marked as a duplicate of 188750 ***

Note You need to log in before you can comment on or make changes to this bug.