Bug 176570 - symlinks pointing to /tmp/prelink files on running system
symlinks pointing to /tmp/prelink files on running system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-12-26 13:54 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 22:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2005-12-26 13:54:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
When launching a program, ppcracer in his case, I ended up getting a permission error for a library that was actually a symlink to a /tmp/prelink<random> file.
There were several prelink files left in the /temp directory which were there for at least several days.
Refer to the thread link described for current suggestions.
During shutdown issue, prelink should exit cleanly. does SIGKILL after 5 seconds cause a problem?

Also, is /tmp a good location for prelink to do its temporary storage or should a location under /var/cache/ be used instead?

Version-Release number of selected component (if applicable):
prelink-0.3.6-2

How reproducible:
Always

Steps to Reproduce:
1. shutdown system
2. launch certain application on system after an hour or so life to system.
3. get error permission denied  referring to library.
  

Actual Results:  It shuts down
The application refers to permission denied on a library. The link to the library is a symlink to a prelink file in /tmp

Expected Results:  system should finish processes or cache information and resume prelinking on reboot.

Additional info:

stated in thread on fedora test list
Comment 1 Jim Cornette 2005-12-29 23:23:42 EST
There is still an ongoing problem with symlinks pointing to #prelink# files.
These files are not under /tmp as what happened with the library where it was
needed for me to re-install the packages.

 locate '#prelink#'
/usr/lib/libdv.so.4.0.1.#prelink#.kl0Smr
/usr/lib/libgsm.so.1.0.10.#prelink#.sHcb2n
/usr/lib/libmp3lame.so.0.0.0.#prelink#.dsFGID
/usr/lib/libpostproc.so.0.0.1.#prelink#.o5U864
/usr/lib/libxvidcore.so.4.0.#prelink#.rtt5zb

were the files left over on my system. These files linked to the symlink that is
setup normally to point to the major library with the minor versioning number.

The excerpt below was linked to /usr/lib/libmp3lame.so.0.0.0.#prelink#.dsFGID
instead of how I edited the symlink after removing the #prelink# versiion with a
different date but same filesize.

 ls -la /usr/lib/libmp3lame.so*
lrwxrwxrwx 1 root root     19 Dec 29 23:10 /usr/lib/libmp3lame.so.0 ->
libmp3lame.so.0.0.0
-rwxr-xr-x 1 root root 289240 Dec 27 17:14 /usr/lib/libmp3lame.so.0.0.0

Comment 2 Jakub Jelinek 2006-01-03 02:44:35 EST
ldconfig in glibc-2.3.90-23 and abov has been changed to ignore prelink
temporaries.  I'll also write a prelink SIGTERM handler, though if you unplug
the cord or kill -9 prelink, prelink temporaries might still be left around.
Comment 3 Jim Cornette 2006-01-06 07:05:19 EST
I am not getting libs symlinked to /tmp lately. I still get these files in lib
and the lib without the #prelink# is in the directory also.

Thanks!

 locate '#prelink#'
/usr/bin/kwikdisk.#prelink#.1rA5Jm
/usr/lib/libGL.so.1.2.#prelink#.Wvw8hK
/usr/lib/libGLU.so.1.3.060401.#prelink#.69UZeK
/usr/lib/libImlib2.so.1.2.1.#prelink#.ChDxbJ
/usr/lib/libSDL-1.2.so.0.7.2.#prelink#.vXlGek
/usr/lib/libdv.so.4.0.1.#prelink#.LgfyBf
/usr/lib/libgsm.so.1.0.10.#prelink#.HOfOSH
/usr/lib/libxvidcore.so.4.0.#prelink#.e0MbnY
[jim@cornette-lt ~]$ cd /usr/lib
[jim@cornette-lt lib]$ ls -laZ *#prelink#*
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libdv.so.4.0.1.#prelink#.LgfyBf
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libGL.so.1.2.#prelink#.Wvw8hK
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libGLU.so.1.3.060401.#prelink#.69UZeK
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libgsm.so.1.0.10.#prelink#.HOfOSH
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libImlib2.so.1.2.1.#prelink#.ChDxbJ
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libSDL-1.2.so.0.7.2.#prelink#.vXlGek
-rwx------  root     root     system_u:object_r:textrel_shlib_t
libxvidcore.so.4.0.#prelink#.e0MbnY
Comment 4 Jim Cornette 2006-02-05 22:52:47 EST
I have not deteced any errors with libraries linked to files in /tmp or with
files with #prelink# as part of the file name. Thanks! I feel the problem is
resolved with changes.

Note You need to log in before you can comment on or make changes to this bug.