Bug 176585 - Use consolehelper
Use consolehelper
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-26 23:47 EST by Rahul Sundaram
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:32:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2005-12-26 23:47:12 EST
Description of problem:

Unlike up2date yum doesnt prompt for password when run as non-root user


Actual results:

Run yum as non-root user and you just get a simple message that you should do
so. We can do better


Expected results:

Yum should prompt for password

Additional info:

Consolehelper is used by up2date, all the system-config-* and generally the
Fedora way to do administrative actions. While this might be a generic yum
feature since consolehelper might be available on distributions that yum
supports it still can be a optional compile time or run time dependency.
Comment 1 Jeremy Katz 2006-04-19 16:32:51 EDT
If you run other console admin tools, eg, lokkit, you don't get prompted -- not
going to change this.

Note You need to log in before you can comment on or make changes to this bug.