Bug 176608 - sylpheed-claws (FE) segfaults in libpangoft2-1.0.so.0
Summary: sylpheed-claws (FE) segfaults in libpangoft2-1.0.so.0
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-27 14:07 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-11 16:49:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb session log (4.98 KB, text/plain)
2005-12-27 14:07 UTC, Ralf Ertzinger
no flags Details

Description Ralf Ertzinger 2005-12-27 14:07:18 UTC
Description of problem:
When starting up sylpheed-claws (from extras), s-c segfaults almost immediately
in libpangoft2. gdb output attached.

Version-Release number of selected component (if applicable):
pango-1.11.1-2


How reproducible:
Always

Steps to Reproduce:
1. start sylpheed-claws
2.
3.
  
Actual results:
segfault

Expected results:
normal startup

Additional info:

Comment 1 Ralf Ertzinger 2005-12-27 14:07:18 UTC
Created attachment 122596 [details]
gdb session log

Comment 2 Ralf Ertzinger 2005-12-27 19:06:19 UTC
xchat goes down at exactly the same point

Comment 3 Matthias Clasen 2006-01-06 15:02:20 UTC
Looks like some font problem to me. What locale is this in ? 
Do you have any strange fonts installed.

Comment 4 Ralf Ertzinger 2006-01-15 01:02:10 UTC
This is in en_US.UTF-8.
I have done some more digging on this and have come up with the following:

a) It has nothing do do with my user-font-config (I moved my locally installed
fonts and .fonts.conf aside and it still happens)

b) It has something to do with the "Fixed" font. I can persuade any gnome
program (including gnome-font-properties) which displays a font selection dialog
to crash by just clicking "Fixed" in the "Family" list.

c) 'fc-match "Fixed"' yields 'kaname-latin1.pcf.gz: "Fixed" "Regular"', which
seems to be owned by fonts-japanese-0.20050222-11.1. The files on the disk
verify against the RPM database.

d) removing fonts-japanese makes selecting "Fixed" safe again, and
sylpheed-claws does not crash any more. 'fc-match "Fixed"' now yields
'console9x15.pcf: "Fixed" "Regular"'. The font is ugly, btw :)

e) reinstall fonts-japanese, and everything goes south as soon as Fixed turns up.

Comment 5 Ralf Ertzinger 2006-01-18 11:54:37 UTC
I noticed yesterday that another font (from fonts-korean) showed the same
behaviour. I then hunted down all fontconfig cache files on the system
(fonts.cache-1, fonts.cache-2, /var/cache/fontconfig), deleted them and reran
fc-cache. Since then all fonts (including Fixed with fonts-japanese) seem to
work again.

Why does fc have to use different cache files for every other release?


Note You need to log in before you can comment on or make changes to this bug.