Bug 1766171 - Freecad: crash to create / open a file
Summary: Freecad: crash to create / open a file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 31
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-28 13:55 UTC by Jorge Rodríguez
Modified: 2020-01-27 21:29 UTC (History)
6 users (show)

Fixed In Version: freecad-0.18.4-1.fc30 freecad-0.18.4-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 01:36:50 UTC


Attachments (Terms of Use)

Description Jorge Rodríguez 2019-10-28 13:55:56 UTC
Description of problem:

Freecad install perfectly but to try open a file the program crash and close direct.

Version-Release number of selected component (if applicable):

freecad-0.18.3-5.fc31.1.x86_64

How reproducible:

Run freecad and try open or create a file


Steps to Reproduce:

1.Install Freecad in fedora 31
2.Run freecad and try open a file or add a new file
3.Freecad crashed

Actual results: Software crash and closes


Expected results: it should work


Additional info: Detected dependences issue 

Dependences problem when running sudo dnf upgrade 

 Problem 1: package freecad-1:0.18.3-5.fc31.1.x86_64 requires libpyside2.cpython-37m-x86_64-linux-gnu.so.5.13()(64bit), but none of the providers can be installed
  - cannot install both python3-pyside2-1:5.12.5-1.fc31.1.x86_64 and python3-pyside2-5.13.1-2.fc31.x86_64
  - cannot install both python3-pyside2-5.13.1-2.fc31.x86_64 and python3-pyside2-1:5.12.5-1.fc31.1.x86_64
  - cannot install the best update candidate for package python3-pyside2-5.13.1-2.fc31.x86_64
  - cannot install the best update candidate for package freecad-1:0.18.3-5.fc31.1.x86_64
 Problem 2: package freecad-data-1:0.18.3-5.fc31.1.noarch requires freecad = 1:0.18.3-5.fc31.1, but none of the providers can be installed
  - package freecad-1:0.18.3-5.fc31.1.x86_64 requires libshiboken2.cpython-37m-x86_64-linux-gnu.so.5.13()(64bit), but none of the providers can be installed
  - cannot install both python3-shiboken2-1:5.12.5-1.fc31.1.x86_64 and python3-shiboken2-5.13.1-2.fc31.x86_64
  - cannot install both python3-shiboken2-5.13.1-2.fc31.x86_64 and python3-shiboken2-1:5.12.5-1.fc31.1.x86_64
  - cannot install the best update candidate for package python3-shiboken2-5.13.1-2.fc31.x86_64
  - cannot install the best update candidate for package freecad-data-1:0.18.3-5.fc31.1.noarch

Comment 1 Richard Shaw 2019-10-28 14:07:36 UTC
I'm gong to have to rebuild freecad. For some reason it didn't pick up the right package when I had to downgrade PySide2...

Comment 2 Richard Shaw 2019-10-28 14:15:32 UTC
On a side note I have built Coin4 for Fedora 30 and up but major library updates are discouraged during a release so only the version of freecad in Rawhide uses it. If you want you can try it out from my COPR but it does move some dependency Coin3D libraries to Coin4 but as long as you only use the Coin3D stack for Fedora you shouldn't run into any package conflicts. 

I'm working on moving from OCE to OCCT (OpenCascade) and will be building it and FreeCAD 0.18.4 there when it's ready.

https://copr.fedorainfracloud.org/coprs/hobbes1069/FreeCAD_NEXT/

Comment 3 Jorge Rodríguez 2019-10-28 14:49:42 UTC
Yes, I though so (About dependences in the release version  and i did doubt about report this or not, Now  I know  that next time it is just wait when it is related to packages dependences ) I will close the bug so thank you for your work with it. I will wait for the 0.18.4. 
Regards

Comment 4 Fedora Update System 2019-10-28 20:57:43 UTC
FEDORA-2019-12930ffaaa has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-12930ffaaa

Comment 5 Fedora Update System 2019-10-29 04:29:07 UTC
freecad-0.18.3-6.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-12930ffaaa

Comment 6 Jorge Rodríguez 2019-11-03 16:18:24 UTC
Fedora 31 is finally out and in the stable repo of fedora is still this version freecad-0.18.3-5.fc31.1.x86_64 what one is not working. Someone should push in stable the new update because the stable branch is containing a breaked package.

Comment 7 Michael Wiktowy 2019-11-04 14:42:26 UTC
Tested FreeCAD version freecad-0.18.3-6.fc31 in updates-testing as per Comment 5
* the dependency issue is resolved (it is no longer trying to install v.5.13.1-2 of python3-pyside2 and python3-shiboken2)
* FreeCAD still crashes on selecting to start a new project or trying to open an existing project

abrt generated crash report contained in https://bugzilla.redhat.com/show_bug.cgi?id=1768480

Comment 8 Richard Shaw 2019-11-04 22:21:51 UTC
As I mentioned, for now it's probably best to use my COPR. I don't have permission to do a major library update (Coin3->Coin4) on released branches of Fedora as it is discouraged:

https://fedoraproject.org/wiki/Updates_Policy#All_other_updates

Comment 9 Jorge Rodríguez 2019-11-05 05:41:46 UTC
Maybe should it be recommendable so retire freecad temporarily from stable branch?  

From COPR it does move some dependency Coin3D libraries to Coin4 even of it shouldn't run into any package conflicts if one stay with stack fedora it is looking how a good solution to the stable branch in fedora 31 imho.

I think that there shouldn't be actually a package what is not working and we is not knowing when it will be it is offering a bad experience though fedora stable branch. But it is just my opinion don't take it like a critique to maintainers because it is not. I hope the stack coin can go fixed.

Regards

Comment 10 Michael Wiktowy 2019-11-05 13:39:22 UTC
(In reply to Richard Shaw from comment #8)
> As I mentioned, for now it's probably best to use my COPR. I don't have
> permission to do a major library update (Coin3->Coin4) on released branches
> of Fedora as it is discouraged:
> 
> https://fedoraproject.org/wiki/Updates_Policy#All_other_updates

The version in the COPR in Comment #2 seems to crash in the same way for me.

Comment 11 Jorge Rodríguez 2019-11-05 14:11:58 UTC
"From COPR it does move some dependency Coin3D libraries to Coin4 even of it shouldn't run into any package conflicts if one stay with stack fedora it is looking how a good solution to the stable branch in fedora 31 imho." I meant that it is not a good solution to the stable branch i missed the sentence.

Like Michael point if COPR is failing, What is going on? Because it is supposed to work for you Richard?

Comment 12 Richard Shaw 2019-11-05 14:40:34 UTC
I'm currently using my COPR and I can load one of the example files without issue on Fedora 30, so this may be a problem specific to Fedora 31 then...

I don't know when I'll have time but I'll setup a VM for Fedora 31. I usually wait about a month after a new release to let things settle down before upgrading :)

I did perform some builds using Coin4... BUT, the rest of the Coin3D stack (SoQt, SIMVoleon, etc) is still built with Coin3. I don't know if this will work or not but as things are already broken I figured it was worth trying.

Also, retirement can only be done on Rawhide/EPEL, not released versions of Fedora.

Comment 13 Fedora Update System 2019-11-05 14:41:56 UTC
FEDORA-2019-817268f20d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-817268f20d

Comment 14 Fedora Update System 2019-11-05 14:41:57 UTC
FEDORA-2019-9a5accc4f3 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9a5accc4f3

Comment 15 Richard Shaw 2019-11-06 01:26:14 UTC
Please test this update and see if it makes any difference.

Comment 16 Fedora Update System 2019-11-06 14:03:31 UTC
freecad-0.18.3-7.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9a5accc4f3

Comment 17 Fedora Update System 2019-11-06 14:13:16 UTC
freecad-0.18.3-7.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-817268f20d

Comment 18 Fedora Update System 2019-11-07 13:35:06 UTC
FEDORA-2019-ec1247a71d has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ec1247a71d

Comment 19 Fedora Update System 2019-11-07 13:35:14 UTC
FEDORA-2019-1ff1241c0f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1ff1241c0f

Comment 20 Michael Wiktowy 2019-11-07 13:55:32 UTC
(In reply to Richard Shaw from comment #15)
> Please test this update and see if it makes any difference.

I tested freecad-0-18.3.7 in updates-testing repo and it still crashes on choosing to open existing/new file under Wayland Gnome3 desktop.

Comment 21 Richard Shaw 2019-11-07 14:12:47 UTC
I just submitted updates with the switch to OpenCASCADE and Coin4 but I don't know if they are going to fix the problem. I installed F31 in a VM which went fine but only got a black screen when trying to boot it. I'm not sure when I'll have time to work on it.

Comment 22 Michael Wiktowy 2019-11-07 14:14:18 UTC
I tested freecad-0-18.3.7 in updates-testing repo on Gnome on XOrg and you can start a new project and open a few of the examples successfully but some of the examples (at least ArchDetail.FCStd and EngineBlock.FCStd) make Freecad crash there also.

I can try to capture an abrt report on XOrg if that would be helpful.

Comment 23 Fedora Update System 2019-11-09 23:20:27 UTC
freecad-0.18.4-1.fc31, opencascade-7.4.0-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-1ff1241c0f

Comment 24 Fedora Update System 2019-11-10 00:39:15 UTC
freecad-0.18.4-1.fc30, opencascade-7.4.0-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ec1247a71d

Comment 25 Richard Shaw 2019-11-12 15:30:35 UTC
Can you test these new updates? If they don't get karma it will be 5 more days before I can push them to stable.

Comment 26 Michael Wiktowy 2019-11-13 04:37:11 UTC
Sorry ... was out of town for a bit ...

Uninstalled COPR freecad pacakge, did a dnf distro-sync, disabled the COPR, did regular package update (dnf update --refresh) and updated using:
dnf install --enablerepo=updates-testing --advisory=FEDORA-2019-1ff1241c0f \*

Still crashed with the following output in the terminal:
Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3c6b0) [0x7f7aa6d1d6b0]
#1  /lib64/libX11.so.6(XDefaultScreenOfDisplay+0x4) [0x7f7aa3112de4]
#2  /lib64/libCoin.so.80(+0x46e92e) [0x7f7aa687592e]
#3  /lib64/libCoin.so.80(glxglue_init+0x40) [0x7f7aa6876240]
#4  /lib64/libCoin.so.80(cc_glglue_instance+0x235) [0x7f7aa686ed85]
#5  0x7f7aa6710b78 in SoGLRenderActionP::isDirectRendering(SoState const*) const from /lib64/libCoin.so.80+0x48
#6  0x7f7aa6712f47 in SoGLRenderActionP::render(SoNode*) from /lib64/libCoin.so.80+0xc7
#7  0x7f7aa6713193 in SoGLRenderAction::beginTraversal(SoNode*) from /lib64/libCoin.so.80+0xa3
#8  0x7f7aa670c0ea in SoAction::apply(SoNode*) from /lib64/libCoin.so.80+0x28a
#9  0x7f7aa8bad64f in Gui::SoBoxSelectionRenderAction::apply(SoNode*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x2f
#10  0x7f7aa8c482b5 in Gui::View3DInventorViewer::renderScene() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x145
#11  0x7f7aa8c1ab19 in SIM::Coin3D::Quarter::QuarterWidget::paintEvent(QPaintEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0xa9
#12  0x7f7aa8c22951 in SIM::Coin3D::Quarter::SoQTQuarterAdaptor::paintEvent(QPaintEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x21
#13  0x7f7aa779034e in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x24e
#14  0x7f7aa783d942 in QFrame::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x22
#15  0x7f7aa7aa83d1 in QGraphicsView::viewportEvent(QEvent*) from /lib64/libQt5Widgets.so.5+0x161
#16  0x7f7aa8c1ad1e in SIM::Coin3D::Quarter::QuarterWidget::viewportEvent(QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x9e
#17  0x7f7aa7324c2e in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x9e
#18  0x7f7aa774dac5 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x75
#19  0x7f7aa7757150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#20  0x7f7aa89f14e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#21  0x7f7aa7324de8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#22  0x7f7aa7788ffa in QWidgetPrivate::sendPaintEvent(QRegion const&) from /lib64/libQt5Widgets.so.5+0x3a
#23  0x7f7aa7789839 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x7e9
#24  0x7f7aa778a553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#25  0x7f7aa778954c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#26  0x7f7aa778a553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#27  0x7f7aa778954c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#28  0x7f7aa778a553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#29  0x7f7aa778954c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#30  0x7f7aa778a553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#31  0x7f7aa778954c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#32  0x7f7aa778a553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#33  0x7f7aa778954c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#34  /lib64/libQt5Widgets.so.5(+0x181ebe) [0x7f7aa775febe]
#35  /lib64/libQt5Widgets.so.5(+0x1822c1) [0x7f7aa77602c1]
#36  0x7f7aa7778415 in QWidgetPrivate::syncBackingStore() from /lib64/libQt5Widgets.so.5+0xa5
#37  0x7f7aa7790708 in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x608
#38  0x7f7aa78a4ef8 in QMainWindow::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x68
#39  0x7f7aa8cb1d9b in Gui::MainWindow::event(QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x18b
#40  0x7f7aa774dad6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#41  0x7f7aa7757150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#42  0x7f7aa89f14e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#43  0x7f7aa7324de8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#44  0x7f7aa7327d8b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) from /lib64/libQt5Core.so.5+0x14b
#45  /lib64/libQt5Widgets.so.5(+0x4957fb) [0x7f7aa7a737fb]
#46  /lib64/libQt5Widgets.so.5(+0x49e11b) [0x7f7aa7a7c11b]
#47  0x7f7aa734fc7a in QObject::event(QEvent*) from /lib64/libQt5Core.so.5+0x22a
#48  0x7f7aa7a89f63 in QGraphicsScene::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x93
#49  0x7f7aa774dad6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#50  0x7f7aa7757150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#51  0x7f7aa89f14e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#52  0x7f7aa7324de8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#53  0x7f7aa7327d8b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) from /lib64/libQt5Core.so.5+0x14b
#54  /lib64/libQt5Core.so.5(+0x2b9f27) [0x7f7aa7379f27]
#55  /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x160) [0x7f7aa4d064a0]
#56  /lib64/libglib-2.0.so.0(+0x51830) [0x7f7aa4d06830]
#57  /lib64/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7f7aa4d068d3]
#58  0x7f7aa7379cb5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0x65
#59  0x7f7aa7323ceb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0x12b
#60  0x7f7aa732ba16 in QCoreApplication::exec() from /lib64/libQt5Core.so.5+0x96
#61  0x7f7aa89783a5 in Gui::Application::runApplication() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x16f5
#62  FreeCAD(main+0x6a6) [0x563508d2dbe6]
#63  /lib64/libc.so.6(__libc_start_main+0xf3) [0x7f7aa6d081a3]
#64  FreeCAD(_start+0x2e) [0x563508d2df4e]

For reference, the following is the complete package list from updates-testing installed on my system:
[root@desktop ~]# dnf list installed |grep @updates-testing
Coin4.x86_64                                       4.0.0-2.fc31                            @updates-testing          
expat-devel.x86_64                                 2.2.8-1.fc31                            @updates-testing          
fontconfig-devel.x86_64                            2.13.92-3.fc31                          @updates-testing          
freecad.x86_64                                     1:0.18.4-1.fc31                         @updates-testing          
freecad-data.noarch                                1:0.18.4-1.fc31                         @updates-testing          
opencascade-devel.x86_64                           7.4.0-2.fc31                            @updates-testing          
opencascade-draw.x86_64                            7.4.0-2.fc31                            @updates-testing          
opencascade-foundation.x86_64                      7.4.0-2.fc31                            @updates-testing          
opencascade-modeling.x86_64                        7.4.0-2.fc31                            @updates-testing          
opencascade-ocaf.x86_64                            7.4.0-2.fc31                            @updates-testing          
opencascade-visualization.x86_64                   7.4.0-2.fc31                            @updates-testing

Comment 27 Richard Shaw 2019-11-13 14:25:54 UTC
But the package from my COPR works?

Comment 28 Michael Wiktowy 2019-11-13 18:24:06 UTC
No ... as per Comment 10, COPR version crashes similarly.

It is far more stable when running under Gnome with XOrg but will still crash on opening some of the example files (but not all of them and new project opens fine).

Comment 29 Richard Shaw 2019-11-13 19:07:04 UTC
Ok, I'm running out of things I can try to "fix" it... I just built the latest git checkout of Pivy in the COPR.

Comment 30 Kyrre Ness Sjøbæk 2019-11-15 09:41:08 UTC
Interestingly, the AppImage on the FreeCad website seems to work, but the HiDPI scaling of that version seems to be all over the place. Still, the 3D stuff runs!

Comment 31 Richard Shaw 2019-11-15 14:15:46 UTC
I got my VM for Fedora 31 working more reliably, I had to increase the video memory from the default of 12MB. 

I could still reproduce the crash when running under Wayland which pretty much confirms that FreeCAD under Wayland just doesn't work yet. I've trolled the FreeCAD forums and found a few threads saying the same ting.

However, when I switched to Xorg I could open all the sample files without issue with the latest packages from my COPR.

Coin3D upstream was naughty and packaged a new 4.0.0 release without bumping the version (or giving ANY indication that it occured other than the archive dates being more recent). I did a diff of the changes and most of it was CMake/CPack updates, not much in the way of "code" but I bumped and rebuilt the package in my COPR just in case it made a difference.

I also updated Pivy from the last release from the FreeCAD github project to "master" to see if that would help. There have been quite a few commits since the last release.

Comment 32 Fedora Update System 2019-11-18 01:17:47 UTC
freecad-0.18.4-1.fc30, opencascade-7.4.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2019-11-18 01:36:50 UTC
freecad-0.18.4-1.fc31, opencascade-7.4.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Kyrre Ness Sjøbæk 2019-11-18 11:00:58 UTC
As said by Richard, it still crashes under Wayland (at least; did not try Xorg) on Fedora 31. However the prebuilt AppImage on the FreeCad website works fine (under Wayland). So the FreeCAD application itself runs under Wayland, but maybe it needs the new Coin3D and the AppImage contains / is statically linked to that library version?

Comment 35 Fedora Update System 2019-11-18 22:47:19 UTC
freecad-0.18.4-1.fc31, opencascade-7.4.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 36 Michael Wiktowy 2020-01-14 18:08:38 UTC
QT and python libraries have been updated and the dependency issue is back and only allowing downgrade of FreeCAD to the version that didn't work. After a --best and --allowerase the following was updated/removed:

Upgraded:
  calibre-4.8.0-1.fc31.x86_64                     python-qt5-rpm-macros-5.13.2-3.fc31.noarch      python2-qt5-5.13.2-3.fc31.x86_64            python2-qt5-base-5.13.2-3.fc31.x86_64         python2-qt5-webkit-5.13.2-3.fc31.x86_64            
  python3-pyside2-1:5.13.2-1.fc31.x86_64          python3-qt5-5.13.2-3.fc31.x86_64                python3-qt5-base-5.13.2-3.fc31.x86_64       python3-shiboken2-1:5.13.2-1.fc31.x86_64      qgnomeplatform-0.6.0-2.fc31.x86_64                 
  qt5-assistant-5.13.2-3.fc31.x86_64              qt5-qt3d-5.13.2-1.fc31.x86_64                   qt5-qtbase-5.13.2-1.fc31.x86_64             qt5-qtbase-common-5.13.2-1.fc31.noarch        qt5-qtbase-gui-5.13.2-1.fc31.x86_64                
  qt5-qtcharts-5.13.2-1.fc31.x86_64               qt5-qtconnectivity-5.13.2-1.fc31.x86_64         qt5-qtdatavis3d-5.13.2-1.fc31.x86_64        qt5-qtdeclarative-5.13.2-1.fc31.x86_64        qt5-qtenginio-1:1.6.2-27.fc31.x86_64               
  qt5-qtgamepad-5.13.2-1.fc31.x86_64              qt5-qtimageformats-5.13.2-1.fc31.x86_64         qt5-qtlocation-5.13.2-1.fc31.x86_64         qt5-qtmultimedia-5.13.2-1.fc31.x86_64         qt5-qtquickcontrols-5.13.2-1.fc31.x86_64           
  qt5-qtremoteobjects-5.13.2-1.fc31.x86_64        qt5-qtscript-5.13.2-1.fc31.x86_64               qt5-qtscxml-5.13.2-1.fc31.x86_64            qt5-qtsensors-5.13.2-1.fc31.x86_64            qt5-qtserialport-5.13.2-1.fc31.x86_64              
  qt5-qtspeech-5.13.2-1.fc31.x86_64               qt5-qtspeech-speechd-5.13.2-1.fc31.x86_64       qt5-qtsvg-5.13.2-1.fc31.x86_64              qt5-qttools-common-5.13.2-3.fc31.noarch       qt5-qttools-libs-designer-5.13.2-3.fc31.x86_64     
  qt5-qttools-libs-help-5.13.2-3.fc31.x86_64      qt5-qtwayland-5.13.2-2.fc31.x86_64              qt5-qtwebchannel-5.13.2-1.fc31.x86_64       qt5-qtwebengine-5.13.2-1.fc31.x86_64          qt5-qtwebkit-5.212.0-0.41.alpha3.fc31.x86_64       
  qt5-qtwebsockets-5.13.2-1.fc31.x86_64           qt5-qtx11extras-5.13.2-1.fc31.x86_64            qt5-qtxmlpatterns-5.13.2-1.fc31.x86_64     

Removed:
  freecad-1:0.18.4-3.fc31.x86_64                                                                                      freecad-data-1:0.18.4-3.fc31.noarch                                                                                     

Complete!
[root@desktop ~]# dnf install freecad
Last metadata expiration check: 0:02:32 ago on Tue 14 Jan 2020 01:55:49 PM AST.
Dependencies resolved.

 Problem: cannot install the best candidate for the job
  - nothing provides libpyside2.cpython-37m-x86_64-linux-gnu.so.5.12()(64bit) needed by freecad-1:0.18.4-3.fc31.x86_64
  - nothing provides libshiboken2.cpython-37m-x86_64-linux-gnu.so.5.12()(64bit) needed by freecad-1:0.18.4-3.fc31.x86_64
=============================================
 Package                                      Architecture  Version          Repository  Size
=============================================
Installing:
 freecad                                      x86_64        1:0.18.3-2.fc31  fedora      38 M
Installing dependencies:
 freecad-data                                 noarch        1:0.18.3-2.fc31  fedora      169 M
Skipping packages with broken dependencies:
 freecad                                      x86_64        1:0.18.4-3.fc31  updates     31 M

Transaction Summary
=============================================
Install  2 Packages
Skip     1 Package

Total download size: 207 M
Installed size: 393 M

Comment 37 antonio montagnani 2020-01-27 21:29:37 UTC
on my systems FreeCad is not workung under Wayland, but iy si fine on Xorg


Note You need to log in before you can comment on or make changes to this bug.