Bug 1766280 - Plans for EPEL 8
Summary: Plans for EPEL 8
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: remmina
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Phil Wyett
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-28 17:39 UTC by Andrew Bauer
Modified: 2022-01-28 06:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-28 06:28:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrew Bauer 2019-10-28 17:39:28 UTC
Do plan to build Remmina for EPEL 8?

Comment 1 Trevor Clark 2020-02-01 15:19:46 UTC
I remote into work computers using RDP + a smart card (yubikey) I need remmina to do that. The flatpak version doesn't  leave work with smart cards.

Comment 2 Simone Caronni 2020-02-08 13:51:05 UTC
Some dependencies have got in, but this one is missing, so it can not be built yet for RHEL/CentOS 8.

https://pagure.io/epel/issue/99

Please note that avahi-devel and the other subpackages are available for CentOS 8 in the PowerTools repository, but the Koji builders for EPEL use RHEL 8.

Comment 3 Trevor Clark 2020-04-20 00:28:00 UTC
Thanks for keeping up on this. This package is important for my use case. I am waiting for this package to update my workstation.

Comment 4 Simone Caronni 2020-05-25 06:16:01 UTC
Still no answer....
https://bugs.centos.org/view.php?id=17235

Comment 5 Andrew Bauer 2020-05-25 12:07:26 UTC
Avahi-devel is currently present in the PowerTools repo so I'm not sure the CentOS folk need to do anything.

I am able to build the netatalk package for el8, which also requires avahi-devel.
https://koji.fedoraproject.org/koji/buildinfo?buildID=1491958

From the build:
> DEBUG util.py:602:  Running transaction
> DEBUG util.py:602:  Installed:
> DEBUG util.py:602:    NetworkManager-libnm-1:1.20.0-5.el8_1.x86_64                                  
> DEBUG util.py:602:    acl-2.2.53-1.el8.x86_64                                                       
> DEBUG util.py:602:    avahi-0.7-19.el8.x86_64                                                       
> DEBUG util.py:602:    avahi-devel-0.7-19.el8.x86_64  


What does your build output look like when you try to build remmina?

Comment 6 Andrew Bauer 2020-05-25 13:30:21 UTC
UPDATE:
I did some testing on my end and the missing package in CentOS repo is avahi-ui-devel.

Perhaps you know that already, but may I suggest adding the adding that detail to your CentOS bug report (or make a new report to get someone's attention).

Comment 7 Andrew Bauer 2020-06-03 13:14:53 UTC
I have emailed the person assigned to CentOS bug 17235. Let's hope this gets some movement on the issue.

Comment 8 Andrew Bauer 2020-06-03 13:16:44 UTC
Disregard the link in the previous message. Rehat bugzilla thought I was referring to a redhat bug.

The real link is here:
https://bugs.centos.org/view.php?id=17235

Comment 9 Andreas Luik 2021-09-29 13:43:05 UTC
Is anybody working on this again?  The blocking issue mentioned above about missing avahi-ui-devel package should not exist anymore:

yum list avahi-ui-devel
Available Packages
avahi-ui-devel.i686                     0.7-20.el8                    powertools
avahi-ui-devel.x86_64                   0.7-20.el8                    powertools

Comment 10 Simone Caronni 2021-09-30 05:42:40 UTC
Thanks for spotting, I will take care.

Comment 11 Simone Caronni 2021-10-01 05:39:20 UTC
Not enough unfortunately:

DEBUG util.py:444:  No matching package to install: 'pkgconfig(gtk-vnc-2.0)'
DEBUG util.py:444:  Not all dependencies satisfied
DEBUG util.py:444:  Error: Some packages could not be found.
DEBUG util.py:598:  Child return code was: 1

https://koji.fedoraproject.org/koji/taskinfo?taskID=76552253

Comment 12 Andreas Luik 2021-10-01 09:04:56 UTC
OK - the gtk-vnc2-devel package is missing in RHEL 8.  I created a request for it: https://bugzilla.redhat.com/show_bug.cgi?id=2009671, but of course I do not know whether/when this will be done.

Comment 13 Simone Caronni 2021-10-03 07:25:06 UTC
Never probably. Tried an attempt also on epel-next, same issue.

Comment 14 Fedora Admin user for bugzilla script actions 2022-01-19 00:26:38 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 15 Phil Wyett 2022-01-21 05:01:27 UTC
Hi all,

I took over the maintaining of remmina for fedora and EPEL two days ago.

I have updated the package in fedora and fixed the core issue for EL builds which was the dependency in #13 which is actually not needed for the remmina VNC plugin.

You will find the first EL8 build of the latest remmina 1.4.23 in EPEL testing - Link below.

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-288d5dd709

If you are able to test and add feedback/karma that would be great or waiting the gatingtime (7 days) and it will move into 'epel8' automatically[1].

[1] I will close this bug when the build goes into stable/public.

Regards

Phil

Comment 16 Andreas Luik 2022-01-21 14:48:47 UTC
We have been able to successfully install remmina from epel-testing, and first tests look good.  Thanks.

Comment 17 Trevor Clark 2022-01-22 01:30:35 UTC
This is fantastic news. I need to use my smart card with RDP to access some computers, and I couldn't find any solutions for RHEL and was waiting on this. great job. thank you.


Note You need to log in before you can comment on or make changes to this bug.