Bug 17663 - Pump doesn't use configuration file parameters
Pump doesn't use configuration file parameters
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: pump (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-18 17:36 EDT by Georg Borgstrvm
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-26 23:55:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georg Borgstrvm 2000-09-18 17:36:13 EDT
I think there is a bug in pump-0.8.2. The problem is that pump doesn't
seem to respect the values in /etc/pump.conf. Including my
configuration file below:

     retries 20
     timeout 120
     script /usr/local/sbin/pump_activated
     device eth0 {
            nodns
     }

When pump configures the interface for the first time, it uses the
retries parameter. However, when pump tries to renew the lease, it falls
back to the default value of 5. I added a couple extra log lines to
dhcp.c.


STARTUP
-------
Sep 16 22:52:01 lillen pumpd[2901]: starting at
                (uptime 67 days, 1:45:40) Sat Sep 16 22:52:01 2000
Sep 16 22:52:01 lillen pumpd[2901]: tries:      21
Sep 16 22:52:04 lillen pumpd[2901]: configured interface eth0


RENEWAL
-------
Sep 16 23:44:33 lillen pumpd[2901]: tries:      6
Sep 16 23:44:34 lillen pumpd[2901]: renewed lease for interface eth0


As You can see, it works when configuring the interface for the
first time, but falls back to the hard corded value DEFAULT_NUM_RETRIES
when renewing the lease.

This is a real problem for me since the dhcp servers at my cable
operator sometimes are really overloaded and I need more than 5
retries. As i workaround, I have changed DEFAULT_NUM_RETRIES, but
would really appreciate a more permanent fix.

I guess that this problem also could concern other parameters in
/etc/pump.conf.

/Georg

BTW. The version of pump that I'm using is from Red Hat Raw Hide.
However, I'm using it on a Red Hat 6.1 machine with more or less
every update applied.
Comment 1 Elliot Lee 2001-08-07 23:46:09 EDT
Can you still produce this behaviour with the pump from RHL 7.1?

Apologies for the unresponsiveness of the previous pump packager...
Comment 2 witten 2001-08-27 17:02:41 EDT
With the pump in Red Hat 7.1, I get somewhat related although not identical
behavior.. On the *first* run of pump (at boot), it completely ignores my
timeout/retry settings in /etc/pump.conf, but if I later run pump manually after
the machine is booted, it appears to honor those settings. I don't know if it's
the same problem as the fellow describes above, but it certainly seems like a
bug. I'm going source diving now, so I'll let you know if I turn up anything.
Comment 3 Nitin Dahyabhai 2002-05-26 23:55:20 EDT
Alas, no, as I lack access to any machines running releases earlier than RHL7.2
at this point.
Comment 4 Elliot Lee 2002-06-21 06:48:12 EDT
pump being deprecated in the current release, I'll assume this is fixed by dhcpcd

Note You need to log in before you can comment on or make changes to this bug.