Bug 176635 - "man radeon" incorrectly shows the "DRI" option as "DRU"
"man radeon" incorrectly shows the "DRI" option as "DRU"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-12-27 23:30 EST by Manu Thambi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 04:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manu Thambi 2005-12-27 23:30:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
In the man page given by "man 4 radeon", in the CONFIGURATION DETAILS section, 
the DRI option is incorrectly specified as DRU. The code to read the option 
correctly uses DRU 

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.49.2

How reproducible:
Always

Steps to Reproduce:
1.man 4 radeon 
2. 
3. 
   

Actual Results:  Option "DRU" "boolean" 
              Enables  DRI  (Direct  Rendering  Infrastructure)  support.   
The default is disabled for Radeon 
              VE/7000 hardware due to instabilities, but enabled by default 
for all other Radeon hardware sup- 
              ported by the DRI. 
 

Expected Results:  Option "DRI" "boolean" 
              Enables  DRI  (Direct  Rendering  Infrastructure)  support.   
The default is disabled for Radeon 
              VE/7000 hardware due to instabilities, but enabled by default 
for all other Radeon hardware sup- 
              ported by the DRI. 
 

Additional info:
Comment 1 Mike A. Harris 2006-02-01 02:52:39 EST
Caused due to a typo in one of my patches.  Fixed in RHEL4 U2 update to the
same patch though.  We should probably update the patch for the next FC4
update also.
Comment 2 Mike A. Harris 2006-02-01 19:01:42 EST
This is an automated note being applied to multiple bugs simultaneously
intended to provide some useful general information.  Please do not reply.

General info for Fedora bug reporters:  Please note that all Fedora Core 4
bugs being filed against any part of the X Window System, should be filed
against the "xorg-x11" bug component.  Bugzilla components correspond to the
src.rpm package from which any application or particular file has been built
from.  "xorg-x11" is the single src.rpm in FC4 which fully contains the
X window system.

All of the other xorg-x11-* components listed in bugzilla, such as xorg-x11-xdm,
xorg-x11-drv-*, and various other components, are those which are part of the
current Fedora Core 5 development process, and are intended only for bugs
being filed against FC5 test releases and "rawhide" which contain the X11R7
release of the X Window system.

When filing FC4 bugs, please ensure you are using "xorg-x11" as a component
and not one of the FC5/devel related components.  This may seem a bit
confusing, since bugzilla presents all of these components as choices
even for FC4.

This seems to be an unfortunate limitation in bugzilla, which does not
appear to be able to restrict individual components to a single product
version, thereby every component in every version appears in the list
for all versions.

When we find a bug filed against a component that is not included in that
particular OS release, we'll do our best to ensure it gets reassigned to
the correct component, however any help users can provide by filing
against the right component, or reassigning misfiled bugs they spot
to the right component would be greatly appreciated.

Thanks in advance, and apologies for any inconveniences.
Comment 3 Mike A. Harris 2006-07-24 04:38:40 EDT
Fixed in rawhide for quite some time now....

Note You need to log in before you can comment on or make changes to this bug.