Bug 1766514 - MCD could shadow errors since the force validation file isn't deleted once used
Summary: MCD could shadow errors since the force validation file isn't deleted once used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Antonio Murdaca
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On: 1766513
Blocks: 1766515
TreeView+ depends on / blocked
 
Reported: 2019-10-29 10:28 UTC by Antonio Murdaca
Modified: 2020-01-22 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1766513
: 1766515 (view as bug list)
Environment:
Last Closed: 2020-01-22 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1148 'None' closed Bug 1766514: [release-4.2] pkg/daemon: remove force validation file if it exists 2020-01-27 19:34:58 UTC
Red Hat Product Errata RHBA-2020:0107 None None None 2020-01-22 10:47:03 UTC

Description Antonio Murdaca 2019-10-29 10:28:24 UTC
+++ This bug was initially created as a clone of Bug #1766513 +++

Description of problem:

MCO added a "force overwrite" file to allow people to fix things when they know they wanted to synchronize to the current state. However, persisting it on disk by default thereafter wasn't explicitly intended - it will silently mask errors.

The flag is much better as a "one time" intervention.

Version-Release number of selected component (if applicable):

from >=4.1


How reproducible:

always


Steps to Reproduce:
1. create a skew in configs (like certs recovery)
2. fix the above using the validation file
3. re-create the skew and notice the error is not bubbled up

Actual results:

errors being shadowed

Expected results:

errors properly bubbled up

Additional info:

Comment 1 Kirsten Garrison 2019-11-07 19:35:18 UTC
Waiting on 1766513 to backport.

Comment 3 Michael Nguyen 2020-01-14 18:28:10 UTC
verified on 4.2.0-0.nightly-2020-01-13-060909

Comment 5 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107


Note You need to log in before you can comment on or make changes to this bug.