Bug 1766518 - cluster_feature_set is not exposed in metrics after feature gate is set
Summary: cluster_feature_set is not exposed in metrics after feature gate is set
Keywords:
Status: CLOSED DUPLICATE of bug 1769779
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.3.0
Assignee: Luis Sanchez
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1731228
TreeView+ depends on / blocked
 
Reported: 2019-10-29 10:33 UTC by Xingxing Xia
Modified: 2019-11-21 12:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 12:22:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xingxing Xia 2019-10-29 10:33:03 UTC
Description of problem:
cluster_feature_set is not exposed in metrics after feature gate is set

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-10-29-011242

How reproducible:
Always

Steps to Reproduce:
1. oc edit FeatureGate cluster # add below and save
...
spec:
  featureSet: "TechPreviewNoUpgrade"
2. Query cluster_feature_set in Prometheus web console

Actual results:
2. Shows "no data"

Expected results:
2. Should be shown like bug 1731228#c3


Additional info:
TK=`oc sa get-token cluster-monitoring-operator -n openshift-monitoring`
oc rsh -n openshift-kube-apiserver-operator deploy/kube-apiserver-operator curl -k -H "Authorization: Bearer $TK" https://localhost:8443/metrics > metrics
vi metrics # check cluster_feature_set, no item seen

Comment 1 Xingxing Xia 2019-11-08 02:38:17 UTC
Added comment in bug 1731228#c15

Comment 3 Michal Fojtik 2019-11-21 12:22:04 UTC

*** This bug has been marked as a duplicate of bug 1769779 ***


Note You need to log in before you can comment on or make changes to this bug.