Bug 1766525 - oc client side should detect large body size and give prompt instead of throwing lengthy error
Summary: oc client side should detect large body size and give prompt instead of throw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-29 10:56 UTC by Xingxing Xia
Modified: 2020-05-04 11:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:15:17 UTC

Description Xingxing Xia 2019-10-29 10:56:23 UTC
Description of problem:
This bug is opened to track bug 1757711#c7

Version-Release number of selected component (if applicable):
Latest oc from openshift-clients-4.3.0-201910250623.git.1.4c88e02.el7.x86_64 still reproduces.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Maciej Szulik 2019-10-31 12:45:27 UTC
This is intentional, to fail the client rather than the server. This will be fixed in the next release when bumping k8s levels.

Comment 3 Maciej Szulik 2020-02-14 15:32:24 UTC
This should be fixed with the current k8s level.

Comment 6 zhou ying 2020-02-17 09:50:47 UTC
Confirmed with latest oc client, can't reproduce the issue now:

[root@dhcp-140-138 ~]# oc version -o yaml
clientVersion:
  buildDate: "2020-02-14T07:28:29Z"
  compiler: gc
  gitCommit: 5d7a12f03389b03b651f963cb5ee8ddfa9cff559
  gitTreeState: clean
  gitVersion: v4.4.0
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64


[root@dhcp-140-138 ~]# time oc create -f /tmp/cve-billion-laugh1.yaml 
error: error parsing /tmp/cve-billion-laugh1.yaml: error converting YAML to JSON: yaml: document contains excessive aliasing

real	0m0.111s
user	0m0.133s
sys	0m0.021s


[root@dhcp-140-138 ~]# time oc create -f /tmp/cve-billion-laugh2.yaml 
error: error parsing /tmp/cve-billion-laugh2.yaml: error converting YAML to JSON: yaml: document contains excessive aliasing

real	0m0.106s
user	0m0.135s
sys	0m0.017s
[root@dhcp-140-138 ~]# time oc create -f /tmp/cve-billion-laugh3.yaml 
error: error parsing /tmp/cve-billion-laugh3.yaml: error converting YAML to JSON: yaml: document contains excessive aliasing

real	0m0.112s
user	0m0.124s
sys	0m0.029s

Comment 8 errata-xmlrpc 2020-05-04 11:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.