Bug 176656 - gnome-power-manager should require dbus-x11
gnome-power-manager should require dbus-x11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-28 13:58 EST by Nalin Dahyabhai
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-16 00:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2005-12-28 13:58:51 EST
Description of problem:
After using yum to update from FC4 to Raw Hide, it's possible to install
gnome-power-manager without having dbus-x11 installed.  The gnome-power-manager
notification icon can't run, though, because there's no session bus for it to
use.  There's no session bus because xinitrc couldn't find /usr/bin/dbus-launch
to start one.

Version-Release number of selected component (if applicable):
0.3.1-2.1

How reproducible:
Always

Steps to Reproduce:
1. Install FC4
2. Use "yum update" to install all updates.
3. Reconfigure yum to hit the development trees.
4. Use "yum update" to update to Raw Hide 20051228.
5. Install gnome-power-manager.
6. Reboot (among other things, this restarts the system message bus).
7. Log in.
8. Attempt to run "gnome-power-manager".
  
Actual results:
  ** (gnome-power-manager:3293): WARNING **: Failed to open connection to dbus
  session bus: Unable to determine the address of the message bus

  This program cannot start until you start the dbussession daemon
  This is usually started in X or gnome startup (depending on distro)
  You can launch the session dbus-daemon manually withthis [sic] command:
  eval `dbus-launch --auto-syntax`

  If this works, add "dbus-lauch --auto-syntax" to ~/.xinitrc

Expected results:
No output, friendly icon shows up in my notification area.

Additional info:
I'm thinking that this is the right way to do it because the other app on my
desktop which is connected to the session bus (eggcups) also explicitly lists
dbus-x11 as a package requirement.
Comment 1 Richard Hughes 2005-12-29 06:11:22 EST
I agree with adding dbus-x11 as a requirement. I've done this in the upstream
spec file also. Thanks, Richard.

Note You need to log in before you can comment on or make changes to this bug.