Bug 1766804 - Apricots does not start as of Fedora 31
Summary: Apricots does not start as of Fedora 31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apricots
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-29 23:32 UTC by Billy DeVincentis
Modified: 2019-11-09 21:20 UTC (History)
2 users (show)

Fixed In Version: apricots-0.2.6-27.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-09 21:20:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Billy DeVincentis 2019-10-29 23:32:45 UTC
Description of problem:Game doesnt start
If attempted from terminal here is the output

Entry NUM_PLANES out of bounds in apricots.cfg
NUM_PLANES must take values between 1 and 6



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2019-10-30 14:52:48 UTC
FEDORA-2019-6a1020511f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a1020511f

Comment 2 Billy DeVincentis 2019-10-30 17:02:18 UTC
I just want to say that I dont believe the problem is the actual config file, I have tried with the original config and by modifying number of planes yet it still wont start, It was starting under previous versions of Fedora

Comment 3 Gwyn Ciesla 2019-10-30 18:05:41 UTC
Correct. It has nothing to do with the config file. The issue was that for some reason the path the program used to find the config file was incorrect. I corrected it, and it works fine now.

Comment 4 Billy DeVincentis 2019-10-31 00:40:45 UTC
Thanks
Im addicted to this stupid little game LOL

Comment 5 Gwyn Ciesla 2019-10-31 00:42:21 UTC
Me too, for a very long time. Upstream is long gone, but I'll keep in running in Fedora as long as I can. :)

Comment 6 Fedora Update System 2019-11-01 17:21:14 UTC
apricots-0.2.6-27.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a1020511f

Comment 7 Creme Brulee 2019-11-04 13:45:02 UTC
The problem with apricots in F31 is that apricots tries to open the config file at the wrong location:

$ strace -e trace=%file apricots
openat(AT_FDCWD, "/usr/local/share/apricots/apricots.cfg", O_RDONLY) = -1 ENOENT (No such file or directory)
Entry NUM_PLANES out of bounds in apricots.cfg
NUM_PLANES must take values between 1 and 6
+++ exited with 1 +++

$ rpm -qf /usr/share/apricots/apricots.cfg 
apricots-0.2.6-26.fc31.x86_64

So the config is at 
/usr/share/apricots/apricots.cfg 
but the game thinks it's at 
/usr/local/share/apricots/apricots.cfg

Comment 8 Gwyn Ciesla 2019-11-04 14:11:13 UTC
Correct, and the update fixes this.

Comment 9 Fedora Update System 2019-11-09 21:20:33 UTC
apricots-0.2.6-27.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.