Bug 176682 - make xconfig fails with gcc-4.1
make xconfig fails with gcc-4.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-29 14:26 EST by Sammy
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 00:08:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-12-29 14:26:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:

gcc 4.1 seems to be more sensitive! Removinh extra qualifications fixes it.

============================================================================
# make xconfig
/usr/lib64/qt-3.3/bin/moc -i scripts/kconfig/qconf.h -o scripts/kconfig/qconf.moc
  HOSTCXX scripts/kconfig/qconf.o
scripts/kconfig/qconf.h:25: error: extra qualification ConfigSettings:: on member readSizes
scripts/kconfig/qconf.h:26: error: extra qualification ConfigSettings:: on member writeSizes
scripts/kconfig/qconf.h:127: error: extra qualification ConfigList:: on member updateMenuList
make[1]: *** [scripts/kconfig/qconf.o] Error 1
make: *** [xconfig] Error 2


Version-Release number of selected component (if applicable):
2.6.14-1.1796_FC5

How reproducible:
Always

Steps to Reproduce:
1. install source rpm and create build directory
2. do make xconfig in the build directory
3.
  

Additional info:

Note You need to log in before you can comment on or make changes to this bug.