Bug 176684 - raid1 install fails
raid1 install fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-29 16:17 EST by Dan Hollis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc5t1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 22:55:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2005-12-29 16:17:45 EST
Description of problem:
raid1 install fails on FC4. take 2 drives (pata, sata, doesnt matter)
partition them both like:
hda1: 128mb
hda2: swap 1gb
hda3: remainder

then:
md0 = hda1+hdc1 = /boot
md1 = hda2+hdc2 = swap
md2 = hda3+hdc3 = /

installer goes through all the motions up till reboot. after reboot, kernel is
unable to mount root (eg, unable to mount device 9,2)

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.follow steps above
2.
3.
  
Actual results:
unable to mount root device 9,2

Expected results:
it should work

Additional info:
by booting into linux rescue, and rebuilding the initrd, it fixes the problem.
so it seems the fedora installer is making an incorrect initrd for raid1.
Comment 1 Dan Hollis 2006-01-02 15:27:35 EST
looks like this is fixed in FC5T1.

Note You need to log in before you can comment on or make changes to this bug.