Bug 17669 - /usr/bin/up2date fails to run on console
Summary: /usr/bin/up2date fails to run on console
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-19 00:25 UTC by John Newbigin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 20:08:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:138 high SHIPPED_LIVE New, enhanced Update Agent for Red Hat Linux 6.x, 7.0 available 2000-12-21 05:00:00 UTC

Description John Newbigin 2000-09-19 00:25:58 UTC
When running from a console with no DISPLAY variable, /usr/bin/up2date exits silently without any warnings/messages etc.  This might not be 
an up2date bug but perhaps with consolehelper.

When /usr/sbin/up2date is invoked directly it functions correctly.

When a DISPLAY value is set /usr/bin/up2date functions correctly

Comment 1 tom 2000-11-02 21:11:53 UTC
I can confirm this bug.  Glad I found it in bugzilla, because it was driving me nuts.  
Installed a fresh 6.2 system without X, had to jump through hoops to manually install 
the dependencies for up2date, and then it wouldn't launch.  When I tried 
'/usr/sbin/up2date' though, it worked fine.

Once I ran all of the available 6.2 updates, I was able to run it as 'up2date'.


Comment 2 Preston Brown 2000-12-21 19:30:09 UTC
fixed in errata being released shortly.


Note You need to log in before you can comment on or make changes to this bug.